Other boards > Third party products

Forest Pack HQ Plants - Problem loading models & materials into scene.

(1/3) > >>


I'm currently a Forest pack lite user until I can get this issue resolved, Using the most recent version of the Forest Lite from this website & Max 2012 64bits.

Our office already has HQ Grass 1, HQ Plants 1, HQ Plants 2 and HQ Palms 1 from previous projects,
I'm new to forest pack and I want to get these models working before i upgrade (Essentially not wanting to spend money before I know these models definitely work)

I've followed the tutorial video and ensured the most recent catalog is installed. Tick
I've followed the necessary steps to list the texture paths, Tick
and clicked the grey plant icons in grass to link the catalog icons to the library file (matlib) This worked for HQ Grass 1, HQ plants 1&2, but not for HQ Palms 1 (These files will not link it just does nothing.)

So I decided I would test the models that did link to their library,
- HQ Plants 1 seems to be working completely fine,
- HQ Grass 1 & HQ Grass 2 constantly flag up errors whereby either the model can't be Xref'd or the material can't be loaded.. or a big window of script appears (See attached image)

Here is some of the text error messages:

Can't find object "fir_4_03" in file "D:\STOCK ELEMENTS\3D OBJECTS\HQ PLANTS 2\fir_4_03.max"
Error loading style, can't xref object "fir_4_03" from "D:\STOCK ELEMENTS\3D OBJECTS\HQ PLANTS 2\fir_4_03.max"

Error loading material "poplar 3 @hqcatalog.ms@getHQRENDERERSUFFIX()NTS 2" from library "D:\STOCK ELEMENTS\3D OBJECTS\HQ PLANTS 1\HQ_Plants_1_matlib.mat"

Can't find max file "D:\STOCK ELEMENTS\3D OBJECTS\hq_grass_1\hq_grass_1\models-@hqcatalog.ms:getHQGrassRenderer())\@hqcatalog.ms:getHQGrassRenderer())-models-lawn-grass-01.max"
Error loading style, can't xref object "lawn-grass i2 01" from "D:\STOCK ELEMENTS\3D OBJECTS\hq_grass_1\hq_grass_1\models-@hqcatalog.ms:getHQGrassRenderer())\@hqcatalog.ms:getHQGrassRenderer())-models-lawn-grass-01.max"

Any help is truly appreciated as I'm heavily depending on being able to use this plugin for a deadline.
Have already contacted 3Dmentor support, whom said to come and ask on this forum.

Thanks in advance! -K

Michal Karmazín:

Most probably your folder structure is different form the "original one". As a general rule, it's always very important when unpacking any libraries for further "catalogue use", to leave its folder structure as it is (it should be unpacked with its full folder structure).

Under the Select installation Path you should always select the "parent" folder (hq_grass_1 for HQ Grass 1, hq_plants_1 for HQ Plants 1, hq_plants_2 for HQ Plants 2 & hq_palms_1 for HQ Palms 1).

Hope that helps.

Best regards,

Hi Michal

I gave that a try and moved the the forest pack install on c: drive just to be extra sure, the folder system is certainly correct as i've tried several different variations,
-Completely untouched folders from when they were unzipped straight from turbosquid downloads section.
-Renamed root folder to exactly what as you suggested, and left the folder structures perfectly as described.
Still exactly the same results, errors finding the models, errors finding materials, no models load properly into forest pack in max

Not entirely sure what is going wrong with this. any help is very welcome.
The free models work perfectly, still getting lots of errors outlined in my first post though.
Best, -K

Michal Karmazín:

Sorry to hear, that the issue still persist. Would you mind to make a screen-grab of unpacked content of the "hq_grass_1" folder? Thanks in advance.

Best regards,

Main Errors are:

"Error loading material "acacia 1 error" from library "filepath".....

"Can't find max file "filepath"\models-@hqcatalog.ms:getHQGrassRenderer())\@hqcatalog.....

"Error loading style can't xref object "bedstraw a 01" from "filepath"\models-@hqcatalog.ms:getHQGrassRenderer())\@hqcatalog

Also worth mentioning that every time this happens, when i go back in to the plugin, all the icons are greyed out again as if they haven't been connected properly... but When i connect them again they turn fully visible every time and load thumbs, its when i select models to "use" that all these errors occur.

I'm no programmer, but i just have a hunch that Forest Pack and these HQ Grass installs aren't communicating very well.

Thanks again for anyone who may be able to shed any light on this, Incredibly frustrating few days, we've all been there.

Michael I just read your reply as I type this post, I've attached a grab for you.


[0] Message Index

[#] Next page

Go to full version