Itoo Software Forum

Author Topic: Xfrog re-installation problem  (Read 2652 times)

NG1558

  • Newbie
  • *
  • Posts: 3
Xfrog re-installation problem
« on: March 11, 2024, 08:59:10 PM »
I recently built a new workstation and I'm trying to get it set up with everything I had before. I'm having a problem installing XFrogCatalog140.exe  When I try to install, it gives me a message saying "Forest Pack Lite or Pro is required to install this catalog. Click OK to visit the Forest Pack download page." I have no option other than to visit this page. Thing is, 3ds max and Forest Pack pro are both installed and working on my new system. I'm really not sure how to proceed from here. Searching here and on the web for help hasn't turned up anything valuable. How can I get this to work?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2521
Re: Xfrog re-installation problem
« Reply #1 on: March 12, 2024, 08:19:42 AM »
Hi,

Since some time ago, the integration with our plug-in has been handled by a corresponding third-party company that provides their vegetation packages. We continue to prepare it exclusively for our The3dGarden plant collections. Thank you for your understanding.

The mentioned catalog (which hasn't been updated for a long time) does not recognize the new FP7/FP8. Currently, you can manually unpack all the content from the lib folder (for example, by opening it in 7Zip) and map it from the Library Browser's UI. Alternatively, you can import the attached registry key to register Forest Pack for these old catalog tools. I hope that helps.

Best regards,

NG1558

  • Newbie
  • *
  • Posts: 3
Re: Xfrog re-installation problem
« Reply #2 on: March 13, 2024, 03:33:20 PM »
The Xfrog stuff is old and not without it's problems, but it's also been quite useful over time. I appreciate the reg key, I will give that a go - manually adding all of this would be a lot. Thank you!

NG1558

  • Newbie
  • *
  • Posts: 3
Re: Xfrog re-installation problem
« Reply #3 on: March 19, 2024, 11:04:57 PM »
This did work, thank you! After importing the reg keys, I was able to install the library. After installation, I changed the 'installed' key back to what it was. All good now :-)