Itoo Software Forum

Author Topic: Railclone problem with Vray proxy  (Read 195 times)

ttmonkeyboy

  • Newbie
  • *
  • Posts: 4
Railclone problem with Vray proxy
« on: April 06, 2021, 08:11:21 AM »
im trying to populate a city block using railclone, however getting different results when i substituted mesh with vray proxy (im looking to populate an entire city and i found vray proxy consumes way less memory). i found railclone unable to slice vray proxy like it did with mesh, is there any workaround to this problem or? im new with railclone and parametric in general. Thanks for any advice!

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3134
    • iToo
Re: Railclone problem with Vray proxy
« Reply #1 on: April 06, 2021, 08:14:12 AM »
Hi. Proxies can't be bent/sliced.
Rokas
iToo Software

ttmonkeyboy

  • Newbie
  • *
  • Posts: 4
Re: Railclone problem with Vray proxy
« Reply #2 on: April 06, 2021, 08:16:55 AM »
so bevel for corner also wont work? bummer

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3706
    • iToo Software
Re: Railclone problem with Vray proxy
« Reply #3 on: April 06, 2021, 08:40:06 AM »
Really there is little benefit using proxies in RailClone.
Probably you noticed they consumes less memory just because object is not generated completely. All sliced and bended segments (which requires more resources) are not being generated.

Proxies should be used only for complete objects (cars, trees, etc.). But even in this case there is not a noticeable improvement, because RailClone already generates instances both for meshes or proxies, when possible.
Carlos Quintero
iToo Software

ttmonkeyboy

  • Newbie
  • *
  • Posts: 4
Re: Railclone problem with Vray proxy
« Reply #4 on: April 06, 2021, 09:05:32 AM »
i remembered seeing this reply on the forum, which is why i did a test by populating a 500m x 500m block with high poly trees using the A2S generator. the vray proxy scene took a couple minutes to render, using only a couple g of memory. the scene with mesh trees took up all my 32g available memory and i stopped the render because light cache wasnt gonna finish any time soon. im sure for smaller scenes it wouldnt make much of a differnece, but since im triyng to populate an entire city im trying to conserve every bit of memory i can. or am i missing something? thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3706
    • iToo Software
Re: Railclone problem with Vray proxy
« Reply #5 on: April 06, 2021, 09:44:46 AM »
If you use the array generator with the default setttings, it will slice the segments at the array's edge, generating tons of sliced trees.
Just go to the Segment properties and turn off "Bend" and "Slice" (Deform tab). That should do the trick.
Carlos Quintero
iToo Software

ttmonkeyboy

  • Newbie
  • *
  • Posts: 4
Re: Railclone problem with Vray proxy
« Reply #6 on: April 06, 2021, 10:08:09 AM »
omg... that's it! thanks!