Itoo Software Forum

Author Topic: 2s array and "x rotation"  (Read 537 times)

manel_reig

  • Newbie
  • *
  • Posts: 25
2s array and "x rotation"
« on: August 31, 2021, 10:36:05 PM »
Hello,

I have some problems when rotating railclone objects with "x rotation", even if I use the "x rotation" option on the array setings, or if I move the vertexs of the "y spline":

1 - If I use only one segment on the default (generator in tile mode), the corner gets cut properly, but I get some "undesired" displacement of the segments on the x axis, is this expected behavior?



2 - If I use segments in default but also in other sections of the array, the corner does not get cut, is this expected behavior?



3 - If I use clipping planes, I encounter two problems, one is that with the same inclination in both planes, the segments are not properly aligned.Already tried to reverse splines, but does not help. Is this expected behavior?   
And also in this mode, I do not get "continuity" in the geometry wich is a big downside:

only with default segment



with default and other sections of the array


thank you very much!
« Last Edit: August 31, 2021, 11:40:16 PM by manel_reig »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1990
Re: 2s array and "x rotation"
« Reply #1 on: September 01, 2021, 04:07:35 PM »
Thanks for the file and the descriptions, we're sorry to hear you are facing issues with these styles. Here are a few notes related to your numbering above:

1 - This one is the easiest to fix. Just detach the Y Spline and use the Y Size instead. Set the Y Mode option to Free to keep the verticals aligned (please see attached file).

2 - This happens because only the geometry that's within the path section closest to the corner will be sliced. In this case a section is defined as the area between Start, End, Corner, or X-Evenly segments. We'll look into this and see if the behaviour can be improved.

3 - I think this is caused by the Sequence operator which is set to reset at spline start. Changing this to Spline Section appears to help and forces both splines to start counting at the same point. Changing the Default mode to adaptive helps the corner to align a little better (please see attached file)


4 - This would appear to be a clipping limitation when the leftmost edge isn't vertical. We'll have to look into it more deeply to diagnose the issue.

I've also included a version that uses nested generators to get around some of these limitations. I hope it helps.

Paul
Paul Roberts
iToo Software