RailClone > RailClone Pro (*)

A2S - Default segment help

(1/1)

PhilJ:
Hi there.

I'm getting stuck when trying to use the A2S generator on a facade.
It's a simple grid system where the default segment is the windows between the grid (I'll attach images and scene)
But no matter what I do I can't get the default segment to be populating all empty spaces between the grid. If I only use Y evenly or only X Corner+X Evenly it works, but not all options
I've been trying this for a while now and I can't seem to figure out what is wrong or how it should be done.

First I thought it might be because I didn't use the different start segments(since it's a closed spline), but this didn't seem to have an effect. I've tried different alignments on the segments, I've tried to enable and disable extend to side on corners and evenly options. I've basically painted myself into a corner and I can't figure it out.

I think this is a user error, but since I can't get there myself I'm asking for some help here. Hope it's an easy mistake to fix :)

Paul Roberts:
This happens because a large segment is being used where the X Evenly, Y evenly, and corners intersect. By default another X Evenly segment is used at these intersections which is pushing the default segment up. we need to target those intersections with different geometry. There's no input in the generator for this so you'll need to use the SegmentYRole macro. To learn more about what this macro does I can recommend this tutorial https://www.youtube.com/watch?v=UX6q_W43Jq8. The Y Role part starts at about 13 minutes.

I've attached an amended version of your file to illustrate how it works.

I hope that helps,

Paul

PhilJ:
Ahh, yes this helps! Thanks a lot :)
Knowing what the generator does by default to fill in the intersection is invaluable information!

Since my style isn't really using the top and bottom inputs I tried to skip these in the macro(I see you plugged the main corner segment into both top at bottom)
Skipping the top segment in the macro worked, but not skipping the bottom one. Could you explain why?

Michal KarmazĂ­n:
When using the Segment Y Role macro, the first row is always treated as the bottom row. To address this, you can either add the appropriate geometry to the macro's Input or create an empty first row by connecting a null Segment to the Generator's Bottom Input.

Best regards,

Navigation

[0] Message Index

Go to full version