Itoo Software Forum

Author Topic: AS2 Auto align issues  (Read 282 times)

PD2965

  • Newbie
  • *
  • Posts: 12
AS2 Auto align issues
« on: January 10, 2023, 01:23:29 PM »
A2S generators aren't staying aligned to the base spline correctly in 3dsmax 2023 / railclone 5.2.8 (autoalign ~ none).

Eg. If we move or rotate the base spline and the railclone object at the same time then the railclone object becomes cropped by the splines original position, the only way to rectify it is to change autoalign to another setting and back.

Please can you let me know how to fix this as it's causing no end of problems.

FYI. It was working perfectly in max 2020 / railclone 4.8

** This is also affecting the railclone to surface script
« Last Edit: January 10, 2023, 02:33:29 PM by PD2965 »

PD2965

  • Newbie
  • *
  • Posts: 12
Re: AS2 Auto align issues
« Reply #1 on: January 10, 2023, 01:32:48 PM »
NB. I have tested all other settings such as heirarchy checking complete etc but nothing appears to alleviate the issue
« Last Edit: January 10, 2023, 02:02:02 PM by PD2965 »

PD2965

  • Newbie
  • *
  • Posts: 12
Re: AS2 Auto align issues
« Reply #2 on: January 10, 2023, 02:01:25 PM »
I have attached a reference file.

As a quick fix can you tell me if we can reset the alignment mode via maxscript?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1966
Re: AS2 Auto align issues
« Reply #3 on: January 10, 2023, 02:48:49 PM »
Hi,

Well, to maintain the optimal performance, the "automatic rebuilding" of the RC object is triggered just on some 3ds max events when using the Extend X/Y Size to Area mode. Using the Display/Build > Build button should do the trick. Optionally, you can disable&enable the  „auto-update” option by:

$.autoUpdate = off;
$.autoUpdate = on;


I hope that helps.

Best regards,

PD2965

  • Newbie
  • *
  • Posts: 12
Re: AS2 Auto align issues
« Reply #4 on: January 10, 2023, 03:03:23 PM »
Thanks Michal!

1. Rebuilding the objects does work. Is there any way to do this globally via maxscript (ie rebuild all objects)?

2. Turning the auto-update off and on again via maxscript doesn't appear to have any affect.

3. Is there any way that we can change this setting so that it automatically rebuilds when moving / rotating etc?

It's an absolute nightmare for us as we have dozens of pre built unit types with multiple brick objects, cladding objects, tile objects that all need moving and rotating into place (rotating 90 degrees makes vertical railclone objects disappear entirely) - this makes is almost impossible to track down each object to correct the alignment.

Also we rely heavily on an extended version of your 'rc_apply_to_poly.ms' script which is also suffering from the same issue.

Cheers

Luke

PD2965

  • Newbie
  • *
  • Posts: 12
Re: AS2 Auto align issues
« Reply #5 on: January 10, 2023, 03:06:22 PM »
Grouping and moving / rotating works, but there's too bigger degree for user error (ie rotating an open group, not realising and submitting an entire sequence to render)

PD2965

  • Newbie
  • *
  • Posts: 12
Re: AS2 Auto align issues
« Reply #6 on: January 10, 2023, 04:00:17 PM »
Grouping and moving / rotating works, but there's too bigger degree for user error (ie rotating an open group, not realising and submitting an entire sequence to render)

It looks like grouping is causing issues with the roof tiles - see attached screen recording.

PD2965

  • Newbie
  • *
  • Posts: 12
Re: AS2 Auto align issues
« Reply #7 on: January 12, 2023, 12:15:03 PM »
Morning.. Is there anything that can be done to resolve this situation?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1966
Re: AS2 Auto align issues
« Reply #8 on: January 13, 2023, 11:04:35 AM »
Hi,

As you’ve pointed out, the $.autoUpdate property doesn‘t rebuild it in this case, but using the $.disabled in the following way should help:

$.disabled = on;
$.disabled = off;


We'll check what can be done in future versions.

Best regards,