Itoo Software Forum

Author Topic: Bug: V-Ray DR Crash  (Read 5722 times)

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3615
    • iToo Software
Re: Bug: V-Ray DR Crash
« Reply #15 on: June 23, 2014, 07:10:34 PM »
Unfortunately not. Although we could to reproduce the crash a couple of times, we didn't find the cause.

Now i'm trying to crash it again, so we can send the debug info to ChaosGroup, but it doesn't fail. We'll continue trying it... :(
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3615
    • iToo Software
Re: Bug: V-Ray DR Crash
« Reply #16 on: June 24, 2014, 09:02:04 AM »
We are also getting this. Any solution?

We are collecting some stats to isolate the problem: what Forest, RailClone and VRay version do you use ?

Thanks,
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3615
    • iToo Software
Re: Bug: V-Ray DR Crash
« Reply #17 on: June 24, 2014, 01:12:56 PM »
If you suffer this problem and use RailClone 2.2, please try with the latest RC 2.3 beta and tell us if there is some change.

We have included a fix in this release that would solve the problem, but we are not sure. This bug is not easy to reproduce, and until now we only got the crash using RC 2.2.
Carlos Quintero
iToo Software

GO3851

  • Newbie
  • *
  • Posts: 5
Re: Bug: V-Ray DR Crash
« Reply #18 on: August 29, 2014, 11:15:22 AM »
Hi,

We are also having this issue for a while now.
The error only happens when clicking cancel on a render; About 1/4 of the time we can go and click ok on all render nodes...
No problem on workstation.

We haven't figured out if the problem is caused by Forest Pack or Railclone but I thought it was Forest pack related.
All workstations and render nodes are running on Forest pack 4.24 and Railclone 2.34 and we're still having this problem.



iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3615
    • iToo Software
Re: Bug: V-Ray DR Crash
« Reply #19 on: August 29, 2014, 12:33:14 PM »
Unfortunately we have done tons of tests, but no clue about what may be causing this problem. It would be some bug clearing data in the cancelling process, but we have verified our code several times and everything seems correct. Also we got the crash only a few times in our test scenes, so it's completely random.

I'm afraid we are stucked with this issue.... :(
Carlos Quintero
iToo Software

GO3851

  • Newbie
  • *
  • Posts: 5
Re: Bug: V-Ray DR Crash
« Reply #20 on: August 29, 2014, 02:26:17 PM »
It seems I was wrong in my previous post. We were running Railclone 2.23 and after updating to Railclone 2.33 the problem does seem to be fixed (or at least better). So build 2.33 fixed a lot for us conserning this issue ! 

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3615
    • iToo Software
Re: Bug: V-Ray DR Crash
« Reply #21 on: August 30, 2014, 08:47:04 AM »
It seems I was wrong in my previous post. We were running Railclone 2.23 and after updating to Railclone 2.33 the problem does seem to be fixed (or at least better). So build 2.33 fixed a lot for us conserning this issue !

Great !. That has sense, because we could not reproduce the problem since the RC 2.3 changes.
Carlos Quintero
iToo Software