Itoo Software Forum

Author Topic: bug: Vrmeshes used as RC objects won't generate box mapping from rc  (Read 621 times)

Screenscene vfx

  • Newbie
  • *
  • Posts: 36
Heya Folks!

I'm working on a scene with a house model that's instanced with railclone and for my wider shots I want to use the box mapping feature to put some larger breakup textures over the scene for variety. What I found was if my houses model is an external vray mesh, the box mapping feature won't work at all. If I set the vray proxy to display the whole mesh and also put a mesh select modifier on top to change it into a dumb editable mesh, the box mapping feature will work fine.

There was a similar issue with forest not taking into account modifiers on vray meshes (I was trying to use noise for some simple rustle in the trees but didn't want to have the full tree model saved in each max scene)

Cheers!

John

Screenscene vfx

  • Newbie
  • *
  • Posts: 36
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #1 on: October 09, 2016, 10:22:24 PM »
Also got a simple plane object that has a distance tex in it's material that references a railclone object. When the rc object is hidden, it works fine, when it's unhidden it doesn't work!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #2 on: October 10, 2016, 01:21:39 PM »
Hi John,

Well, RailClone can handle any object from the scene that has polygonal geometry - in case of proxy object, that should use the Show whole mesh mode to generate whole mesh required for RailClone's operations. Also setting up the UV mapping before using such object (like a simply by a UVW Map modifier) is higly recommendable.
Quote
"got a simple plane object that has a distance tex in it's material that references a railclone object. When the rc object is hidden, it works fine, when it's unhidden it doesn't work"
In our internal tests the VRayDistanceTex works as supposed (as you can see on attached screen-shots). Would you mind to specify used 3ds max / RailClone / renderer versions? Thanks in advance.

Best regadrs,

Screenscene vfx

  • Newbie
  • *
  • Posts: 36
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #3 on: October 13, 2016, 01:59:52 PM »
Heya!

It's a bit of a shame it won't do some kind of internal magic just to keep the viewport overhead nice and light but all good :)

We're on forest 5.1 and railclone pro 2.7 here, will package up a part of the scene with the issue!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #4 on: October 13, 2016, 03:47:05 PM »
Hi,

Feel free to set such object Display Properties to Display to Box (though under MeshProxy params it'll be set correctly to show whole mesh, this way it'll be displayed as a box and RailClone will have all geometry needed for its calculations). Hope that helps.

Best regards,

Screenscene vfx

  • Newbie
  • *
  • Posts: 36
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #5 on: November 01, 2016, 10:09:06 PM »
Hi Michal!

I got another occurrence of the distance tex issue, I've to run another test on it but there seems to be an issue when rendering sequences. Max 2016, railclone 2.7 and vray 3.304. I've got a 221 frame shot of a docks. Railclone is being used to create the docks wall and there's a water plane which uses vray displacement and the phoenix tex to make a moving surface. I've mixed in the distance tex as a mask on the plane's material to blend between water and a white foam and what I found on a recent render on deadline is that the first frame a render node does works totally fine but after that, the distance tex no longer works, as if it's not seeing the mesh made by railclone. I put through another render but this time turned off use instancing engine and put a mesh select modifier on top of the stack and this time it worked fine.

Any ideas? might be worth putting through a sequence of your test to see if it behaves?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #6 on: November 02, 2016, 04:43:00 PM »
Hi,

When using the VRayDistanceTex, please disable the Use Instancing Engine option to avoid this kind of issues. Having this option enabled, such map doesn't have the mesh data needed to perform correctly.

Best regards,
« Last Edit: November 02, 2016, 04:50:22 PM by Michal Karmazín »

Screenscene vfx

  • Newbie
  • *
  • Posts: 36
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #7 on: November 05, 2016, 01:54:27 PM »
Will do - thanks for that!

Pixelab

  • Jr. Member
  • **
  • Posts: 74
  • Suave mari magno
    • pixelab.be
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #8 on: November 07, 2016, 09:16:43 AM »
Wow didn't knew about that trick (use show whole mesh to use proxies)

Quote
Also setting up the UV mapping before using such object (like a simply by a UVW Map modifier) is higly recommendable.

If the proxy geometry has UVW, do you still have to add an UVW modifier on the proxy object ? Also a UVW map modifier will mess up your your UV, so I guess you mean a UVW mapping add, a UVW Xfrom, or a Unwrap UVW ?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: bug: Vrmeshes used as RC objects won't generate box mapping from rc
« Reply #9 on: November 07, 2016, 04:17:37 PM »
Hi,

If such object has been properly "UV mapped" before converting to a VRayProxy object, there's no need to apply any mapping modifier and such mapping will be inherited.

Best regards,