Itoo Software Forum

Author Topic: empty segment and sequence problem  (Read 411 times)

manel_reig

  • Newbie
  • *
  • Posts: 25
empty segment and sequence problem
« on: July 22, 2021, 10:18:58 PM »
Hello,

I have a problem when trying to use an "empty segment". The sequence node seems to not respond correctly to it. When I use a segment with geometry everything works as expected, but when I try it with an empty segment it does not work. The sequence is two elements 1 time each element. With the "empty segment" I get 2 and 1. See image attached:


I guess the error comes from the empty segment...I tried giving measurement to Fixed size and padding and none seems to work. How do I set an empty segment properly?

thank you

Dragan

  • Hero Member
  • *****
  • Posts: 879
Re: empty segment and sequence problem
« Reply #1 on: July 22, 2021, 11:56:13 PM »
Hi,
What is your goal? If you want every second evenly space empty, then just double the Evenly Distance.
However, if you need sequence or compose, the Empty/Null segment will terminate Sequence/Compose. Adding some value to X fixed size should activate Null so Sequence will continue (that can be some very small value like 0.001cm).
Sometimes I use a trick to simulate Null: Add a simple geometry as a box instead of Null but set the Transform Scale X/Y/Z to 0

« Last Edit: July 23, 2021, 07:56:35 AM by Dragan »

manel_reig

  • Newbie
  • *
  • Posts: 25
Re: empty segment and sequence problem
« Reply #2 on: July 23, 2021, 10:42:05 AM »
thanks for your answer, sadly I can not open your file, 3dsmax 2018 here...yes, the goal is to simply put a lamp and a empty segment in a sequence....sadly doubling the  evenly distance does not work in all parts of the spline, I guess it is because the arrays are in adaptative and also the evenly is in adaptative:


I tried to use the "empty segment" giving value to the pading or the fixed size...that does not work.

Quote
Sometimes I use a trick to simulate Null: Add a simple geometry as a box instead of Null but set the Transform Scale X/Y/Z to 0


Yes, I am aware that are other ways to do things, but I am just trying to relearn the basics here after a while not using railclone. I used "empty segments" before, but I do not understand why it is not working with the "sequence" node..my guess is that I do something wrong, but since you tell me that and empty segment with value in the "Fixed size" should do the work... :o...

so, my questions are: How do I configure an empty segment in order to work? Can I use an empty segment in combination with a sequence node?

thank you

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2083
Re: empty segment and sequence problem
« Reply #3 on: July 23, 2021, 10:59:42 AM »
Thanks for reporting this. It would appear something is not behaving as it should. You can see the issue when you swap standard geometry for a null. Apologies for that, we're looking into it!



Paul
Paul Roberts
iToo Software

Dragan

  • Hero Member
  • *****
  • Posts: 879
Re: empty segment and sequence problem
« Reply #4 on: July 23, 2021, 11:27:08 AM »
2018

manel_reig

  • Newbie
  • *
  • Posts: 25
Re: empty segment and sequence problem
« Reply #5 on: July 23, 2021, 03:26:08 PM »
thank you Dragan and Paul...a workaround seems to be using "empty segment" variation tha Dragan suggested, scaling it to 0,0,0 when trying to use it in the evenly combined with a sequence