Itoo Software Forum

Author Topic: enter key doesn't work  (Read 982 times)

lukx

  • Full Member
  • ***
  • Posts: 120
    • lukxCGI
enter key doesn't work
« on: August 09, 2017, 09:00:17 AM »
Any chance to make enter key work when entering numbers in style editor? Right now I can't accept new number by clicking enter.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: enter key doesn't work
« Reply #1 on: August 10, 2017, 01:14:13 PM »
Hi, it seems to work fine here. Numeric values are accepted without problems clicking enter...

Please, would you detail the problem ? What Max version?

Thanks.
Carlos Quintero
iToo Software

lukx

  • Full Member
  • ***
  • Posts: 120
    • lukxCGI
Re: enter key doesn't work
« Reply #2 on: August 23, 2017, 02:54:02 PM »
3dsmax 2018 and 2017. Whatever I type in and click enter nothing happens and I need to click somewhere else than the number is accepted. But the problem is only in Style editor.
« Last Edit: August 23, 2017, 03:07:32 PM by lukx »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: enter key doesn't work
« Reply #3 on: August 24, 2017, 08:56:52 AM »
Sincerely, i have not idea what may be the problem. I cannot reproduce it in Max 2017/2018, RC 3.0.8:



We'll test in other computers. If someone have same problem, please report it, so hopefully we can find some coincidence.

Carlos Quintero
iToo Software

lukx

  • Full Member
  • ***
  • Posts: 120
    • lukxCGI
Re: enter key doesn't work
« Reply #4 on: August 24, 2017, 09:10:24 AM »
hmm, maybe it's because I'm using bluetooth keyboard (I don't have any other keyboard type to test it)

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: enter key doesn't work
« Reply #5 on: August 25, 2017, 10:06:37 AM »
Definitively this issue happens only with some keyboards.
One of our collaborators could reproduce it using a bluetooth keyboard, but other models as the Logitech wireless MK220 work fine.

I think it may a bug in the API we use for the Style Editor (Qt 4), so it has difficult solution from our side. We'll take a look to it anyway.
Carlos Quintero
iToo Software