Itoo Software Forum

Author Topic: Error loading Material Library  (Read 235 times)

Tom_1028

  • Newbie
  • *
  • Posts: 6
Error loading Material Library
« on: May 10, 2022, 02:31:28 AM »
Hi,

I run RailClone Pro 5.1.2 on 3ds Max 2022.3.3 Security Fix (24.0 - 24.3.3.3511) with Corona 8.

When I create a RailClone object and I choose a style in the Library Browser, I have the following error:

Error loading material library: "E:\___ iTOO SOFTWARE\RailClone Pro Library\matlib\corona_v2.mat"

I searched the forum for this issue and found that thread: https://forum.itoosoft.com/railclone-pro-(*)/error-loading-material-library-6786/

So I checked what the value of Computer\HKEY_CURRENT_USER\SOFTWARE\Itoo Software\RailClone Pro\MatlibDir key is, and it is:

C:\Users\***myUsername***\AppData\Local\Itoo Software\RailClone Pro\matlib


To my understanding, this error happens because:

1) there is no "matlib" folder in E:\___ iTOO SOFTWARE\RailClone Pro Library.
Instead there is a lib\default1 folder, which contains the following sub-folders:
        _ Architecture
        _ Civil engineering
        _ Entourage and Props
        _ Industrial
        _ Landscape Architecture

2) the file corona_v2.mat is actually present in C:\Users\***myUsername***\AppData\Local\Itoo Software\RailClone Pro\matlib


Can you please explain me  how to solve this issue?

Thank you very much,

It's still time to change the road you're on.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1823
Re: Error loading Material Library
« Reply #1 on: May 10, 2022, 08:05:23 PM »
Hi,

If you decide to "move" the RailClone library, you should also copy macros, maps and matlib folders to the same folder where the lib is and define correspondingly the following values:

[HKEY_LOCAL_MACHINE\Software\Itoo Software\RailClone Pro\LibraryDir]
"RailClone Library"="<yourCustomPath>\\lib\\default1"

[HKEY_LOCAL_MACHINE\Software\Itoo Software\RailClone Pro\MacroDir]Library]
"Library"=<yourCustomPath>\\macros"

[HKEY_LOCAL_MACHINE\Software\Itoo Software\RailClone Pro\MatlibDir]

"Materials"="<yourCustomPath>\\matlib"

[HKEY_LOCAL_MACHINE\Software\Itoo Software\RailClone Pro\TexturePaths]
"1"="<yourCustomPath>\\maps"

You might find helpful the following link regarding the recommendable set up:

https://forum.itoosoft.com/faq-18/installing-railclone-3-assets-in-a-shared-network-path/

If you prefer using environment variables, setting corresponding environment variables would do the trick also. Just let me mention, that if both registry keys and environment variables are defined, the variables have precedence over keys (the priority order is Environment Variables > HKLM > HKCU).

I hope that helps and please let us know if that's all working fine or if you are still facing troubles with it. Thanks in advance.

Best regards,
« Last Edit: May 10, 2022, 09:05:19 PM by Michal Karmazín »

Tom_1028

  • Newbie
  • *
  • Posts: 6
Re: Error loading Material Library
« Reply #2 on: May 11, 2022, 09:39:04 AM »
Wonderful, it works like a charm, thank you  :)

Do I have to do the same process with Forest Pack Pro, given I've changed the default installation path as well?
It's still time to change the road you're on.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1823
Re: Error loading Material Library
« Reply #3 on: May 11, 2022, 03:20:03 PM »
You're welcome. I'm glad to hear, that it helped and wish you the best results. Yes, the same applies to both our plug-ins (the matlib folder should be copied to the same folder where the lib is).

Best regards,

Tom_1028

  • Newbie
  • *
  • Posts: 6
Re: Error loading Material Library
« Reply #4 on: May 12, 2022, 02:51:54 AM »
Thank you.
I moved Forest Pack Pro folders in the new location as well, it works.

But: although all RC and FP maps in my scene are found and rendered correctly, they are marked as "Found" and not as "Ok" in the Asset Tracking.

Ideally I want them to be marked as Ok and not as Found: is there a way to achieve this apart from manually relinking them?

I also have a question about the Itoo Update Manager: in the tutorial page (https://forum.itoosoft.com/faq/installing-forestpack-6-assets-in-a-shared-network-path/) it is said to turn the Update Manager off, which I did.

But how am I going to know when an update is available?
And if I ever do an update, will it occur in the newly defined folders or in the default location on the C drive (which I don't want)?

Thank you in advance for your support

« Last Edit: May 12, 2022, 02:53:28 AM by Tom_1028 »
It's still time to change the road you're on.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1823
Re: Error loading Material Library
« Reply #5 on: May 12, 2022, 11:36:21 AM »
Hi,

Well, if you set these registry keys correspondingly, any new FP / RC object should point to the folder defined there. That said, if the status under the Asset Tracking tool says Found for "previously created objects", there shouldn't be any problem with it (although it's not showing the correct folder). If wanted, please feel free to map it to the right folder by right click on selected assets and choosing Set Path..., then in Specify Asset Path you can map it to your folder location, but it's not really necessary.

Let me add, that setting the "Check For Updates"="false" option is mentioned for "other workstations" - to avoid this check on nodes.

Best regards,