Itoo Software Forum

Author Topic: Everything is MASSIVE!  (Read 2059 times)

scott

  • Newbie
  • *
  • Posts: 31
Everything is MASSIVE!
« on: June 04, 2013, 07:57:48 PM »
Every object from the library that I bring into my scene is massive.  I've got 35' high streetlamps, lol.  Forest Pack Pro never had this problem.

Is there a setting I'm missing?  Having to mess with a global scale every time is going to be a pain.

Tnx
« Last Edit: June 04, 2013, 08:02:54 PM by scott »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Everything is MASSIVE!
« Reply #1 on: June 04, 2013, 08:19:38 PM »

The library objects should be scaled automatically. Please, tell me your Max version, units setup and the exact streetlamp model you are importing.

Carlos Quintero
iToo Software

scott

  • Newbie
  • *
  • Posts: 31
Re: Everything is MASSIVE!
« Reply #2 on: June 04, 2013, 11:41:55 PM »
Hi, using Design 2013, 64bit.

Units:

System Unit is 1unit to inches.
Display is set to Feet with fractional inches.

Doesn't seem to matter if I change my system units to centimeters or meters - the problem is the same.

All RailClone objects suffer from this issue.  For instance, the picket fence is coming in at 10' high.   :o

With this setup I've never had an issue with ForestPack Pro...

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Everything is MASSIVE!
« Reply #3 on: June 05, 2013, 12:11:09 AM »

It works fine here, the picket fence has 1.27m height (about 4.1').

Please, select the RailClone object, press F12 and check if it's scaled. If not, reset Max, create a test scene using the picket fence, and send us the file.

Carlos Quintero
iToo Software

scott

  • Newbie
  • *
  • Posts: 31
Re: Everything is MASSIVE!
« Reply #4 on: June 05, 2013, 04:34:02 AM »
Reset the scene.  Same problem.  I'm sending you a download link.

Tnx

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Everything is MASSIVE!
« Reply #5 on: June 05, 2013, 10:00:39 AM »
Ok. The object in your scene is wrong scaled, but if reload the fence from the library (using the same units) it is loaded correctly. This seems a problem specific to your configuration, but not sure what.

Please, do the following test:

1) Reset Max. Load the scene C:\Program Files (x86)\Itoo Software\RailClone Pro\lib\default1\Architecture\Fences\Vynil\fencing_vynil1.max. If the Units are different, select Adopt the File's Unit Scale.
2) What is the size of the picket fence (_RC_fencing_vynil_4) ?
3) Does it change repeating the process but selecting Rescale the file Objects to the System Unit Scale ?
4) Reset Max and merge all objects of the above scene. What is the result ?
5) Send us the file 3dsmax.ini stored at C:\Users\<your username>\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU

One more question: what Max update have you installed, PU6 ?

Thanks,
« Last Edit: June 05, 2013, 10:08:12 AM by iToo »
Carlos Quintero
iToo Software

scott

  • Newbie
  • *
  • Posts: 31
Re: Everything is MASSIVE!
« Reply #6 on: June 13, 2013, 12:52:00 AM »
I reset, loaded the scene as instructed.

The height of the fence is 315cm or 10'-6" high!  This was after a reset.  I did notice my display units were set to Metric, but  System Units remained as inches.  Once I changed inches to cm, the height was correct at 124cm.

I never get the 'Rescale the file Objects to the System Unit Scale' option.  Ever.

Merging was fine.

The .ini file settings I think you are looking for are:
UnitType=4
UnitScale=1

Tnx

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Everything is MASSIVE!
« Reply #7 on: June 13, 2013, 12:53:45 PM »
Ok, i can reproduce the problem here:

Please, check the "Respect System Units in Files" checkbox, if your System Units configuration: it must be enabled. That should solve the problem.

Carlos Quintero
iToo Software

scott

  • Newbie
  • *
  • Posts: 31
Re: Everything is MASSIVE!
« Reply #8 on: June 14, 2013, 03:49:26 AM »
LOL.  Jeesh, I don't know how I missed that.  hah.  Tnx for the patience and assist!