Itoo Software Forum

Author Topic: Forming road junctions with Railclone  (Read 408 times)

Rio

  • Newbie
  • *
  • Posts: 40
Forming road junctions with Railclone
« on: August 20, 2021, 10:57:01 AM »
Thought I'd share this as I googled it and saw a few posts saying Railclone doesn't support junctions. I thought of this idea, using ShapeBooleans and references to create an are from a couple of base splines. The process is broadly this:

Draw base splines for centre of road paths
reference copy these, add a spline offset modifier (double sided, don't keep original, closed end to create a closed shape) to them and union them in a Shape Boolean. Add a spline chamfer modifier to round off the corners. This forms the base object for an Array2S extended to clipping area for the road surface

Instance copy the original base splines and add them to another Shape boolean, this forms the baseline for a Linear array for the centre line for the road

Another linear array is made using the offset spline for the kerb/pavement

I haven't managed to work out a way to get the stop lines to cross the junction proerly when it's off adjacent, possibly just a broken line running all around the central road, hidden in places by the kerb.

« Last Edit: August 20, 2021, 11:00:38 AM by Rio »

Rio

  • Newbie
  • *
  • Posts: 40
Re: Forming road junctions with Railclone
« Reply #1 on: August 20, 2021, 11:02:24 AM »
<iframe width="960" height="790" src="https://screencast.autodesk.com/Embed/Timeline/32016351-188b-4a5d-a5f7-049de14cdd11" frameborder="0" allowfullscreen webkitallowfullscreen></iframe>


Rio

  • Newbie
  • *
  • Posts: 40
Re: Forming road junctions with Railclone
« Reply #3 on: August 20, 2021, 11:03:31 AM »
How do you embed a video on this forum anyway!?

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2087
Re: Forming road junctions with Railclone
« Reply #4 on: August 20, 2021, 11:31:03 AM »
Thanks for the nice video. That solution looks like it works pretty well, and it's nice to see Spline Offset in the mix too!

Regarding embedding, I'm afraid it's disabled in the forum for users as a security measure. Links all work fine though

All the best,

Paul
« Last Edit: August 20, 2021, 11:41:43 AM by Paul Roberts »
Paul Roberts
iToo Software