Itoo Software Forum

Author Topic: Mixed License/Installation use  (Read 871 times)

visionsbox

  • Newbie
  • *
  • Posts: 5
Mixed License/Installation use
« on: September 22, 2021, 05:37:46 PM »
Hi!
We rarely use Rail Clone or Forest Pack - that's why we only notice that today.

We have one (!) network license that the artist who needs it can get. For this I installed the "network" version on all computers in the network. We use computers here for rendering but also as a workstation.
ince version 1.5 of the license server this is no longer possible. Now only the single computer in the network that currently has the network license renders. All other "rendernodes" get stuck with Railclone or, in the case of Forestpack, do not load the elements.

What did i miss? What can I do? What am I doing wrong?

Sincerly,
Simon

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • iToo Software
Re: Mixed License/Installation use
« Reply #1 on: September 23, 2021, 01:33:58 PM »
Hi,
What render software do you use ? Backburner or other ?

When plugin is rendering on unattended mode (Backburner, Distributed Rendering, Batch mode, etc), it doesn't fetch any license from the License Server.
This has not changed, and it should not be affected by the version of the License Server (because is not used).

Instead, if you render manually from the workstation, then a license is required. Basically our software works in the same way that Max licenses.

Carlos Quintero
iToo Software

visionsbox

  • Newbie
  • *
  • Posts: 5
Re: Mixed License/Installation use
« Reply #2 on: September 23, 2021, 03:29:53 PM »
Hi!
We're using Royal Render: https://www.royalrender.de/index.php/startseite.html

I checked it again and with "Distributed Rendering" it works as expected. Then something must go wrong with Royal Render. I'll contact the support and get back when I know more.

Thanks for the hint!

visionsbox

  • Newbie
  • *
  • Posts: 5
Re: Mixed License/Installation use
« Reply #3 on: September 28, 2021, 10:51:35 AM »
Hi,

I did a few more tests and I'm in contact with Holger from RoyalRender (RR)

Test A with 3ds Max 2021.3, ForestPack 6.3.1, RailClone 4.2.1, License Manager 1.4.2 and RoyalRender 8.3.0, 1 workstation with GUI (catching all Network License) and 1 RenderNode: renders without problems

Test B with 3ds Max 2021.3, ForestPack 7.1.2, RailClone 4.3.2, License Manager 1.5.0 and RoyalRender 8.3.0, 1 workstation with GUI (catching all Network License) and 1 RenderNode: only the workstation renders; the RenderNode reports: "There are not available License of RailClone in the License Server. Please contact ... " (same for Forest Pack) and freeze.

Holger from RoyalRender has the following suspicions:
Quote
RR uses 3dsmax batch, the commandline used is:
C:\Program Files\Autodesk\3ds Max 2021\3dsmaxbatch.exe    renderScriptfile.py

Note that RR is using the old executable  3dsmaxcmd.exe for 3dsmax 2014-2020.
And the new 3dsmaxbatch.exe for 2021-2022.
Can this be the issue? That the new 3dsmaxbatch.exe was not tested with ForestPack?

Do you have an idea?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • iToo Software
Re: Mixed License/Installation use
« Reply #4 on: September 28, 2021, 02:02:22 PM »
Hi,

Probably it works with FP6, but fails with FP7, because we had to change the way that computer is identified as render node.
Previously we used an old workaround, but caused some problems with Max 2022. Now we use the method suggested by Autodesk.

Please hold on, while we do some tests here with 3dsmaxbatch.exe.

Meanwhile, you may force to use the old detection method, setting altNetRenderCheck = 1 in forestpack.ini, which is located at
C:\Users\<user name>\AppData\Local\Autodesk\3dsmax\< max version> - 64bit\ENU\en-US\plugcfg

Note this configuration is local to each render node, so you should edit each one of them manually.

« Last Edit: September 29, 2021, 12:45:08 PM by iToo »
Carlos Quintero
iToo Software

visionsbox

  • Newbie
  • *
  • Posts: 5
Re: Mixed License/Installation use
« Reply #5 on: September 29, 2021, 09:26:30 AM »
Meanwhile, you may force to use the old detection method, setting altNetRenderCheck = 0 in forestpack.ini, which is located at
C:\Users\<user name>\AppData\Local\Autodesk\3dsmax\< max version> - 64bit\ENU\en-US\plugcfg
Thanks for your reply!

The workaround is working! Note that the option has to be set with altNetRenderCheck=1.

Is there a similiar workaround for RailClone?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1772
Re: Mixed License/Installation use
« Reply #6 on: September 29, 2021, 12:41:03 PM »
Hi,

I'm glad to hear that it helped. In the case of the RailClone Pro plug-in, you can find the altNetRenderCheck option (by default set to 0) under the following registry key:

Computer\HKEY_CURRENT_USER\SOFTWARE\Itoo Software\RailClone Pro

Anyway, we've been looking into this problem and we reproduced it here - the problem might come from the C:\Users\%USERNAME%\AppData\Local\Autodesk\3dsmax\2022 - 64bit folder.

When Max runs on interactive mode, it creates a file Plugin.UserSettings.ini, which contains the path to the Max "plugins" folder (where Forest Pack & RailClone plug-ins are installed). In this way (the Max 2022 path may be different in your case):

[Directories]
Additional MAX plug-ins=C:\3dsmax2022_64\3ds Max 2022\PlugIns\
[Help]


It seems when Max is launched in some other way - like by Deadline in render mode, this file is not created, and plugins stored in the path are not loaded.

How to fix it:
  • Delete the folder C:\Users\%USERNAME%\AppData\Local\Autodesk\3dsmax\2022 - 64bit from render node, where %USERNAME% is the Windows user which runs the job.
  • Launch at least one render.
  • When 3ds Max is launched, it should create the folder mentioned above. If it doesn't exist, please double-check that the %USERNAME% name is correct.
  • Once you check that folder exists, copy the file Plugin.UserSettings.ini from one of your workstations.
I hope that helps.

Best regards,

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • iToo Software
Re: Mixed License/Installation use
« Reply #7 on: September 29, 2021, 12:48:32 PM »
The workaround is working! Note that the option has to be set with altNetRenderCheck=1.

Good to know.
And you're right, it should be altNetRenderCheck=1 (sorry, my fault). I edited my original post.

Carlos Quintero
iToo Software

visionsbox

  • Newbie
  • *
  • Posts: 5
Re: Mixed License/Installation use
« Reply #8 on: September 30, 2021, 03:00:48 PM »
Hi,
thanks for answering!

Hi,

I'm glad to hear that it helped. In the case of the RailClone Pro plug-in, you can find the altNetRenderCheck option (by default set to 0) under the following registry key:

Computer\HKEY_CURRENT_USER\SOFTWARE\Itoo Software\RailClone Pro

Nice to know - thanks!

Anyway, we've been looking into this problem and we reproduced it here - the problem might come from the C:\Users\%USERNAME%\AppData\Local\Autodesk\3dsmax\2022 - 64bit folder.

When Max runs on interactive mode, it creates a file Plugin.UserSettings.ini, which contains the path to the Max "plugins" folder (where Forest Pack & RailClone plug-ins are installed). In this way (the Max 2022 path may be different in your case):

[Directories]
Additional MAX plug-ins=C:\3dsmax2022_64\3ds Max 2022\PlugIns\
[Help]


It seems when Max is launched in some other way - like by Deadline in render mode, this file is not created, and plugins stored in the path are not loaded.

Sorry - but this didn't helped in my case. On the one hand, the file with the correct entry already exists in the target directory of the RenderUsers and, on the other hand, ForestPack already loads, because it reports that it does not get a license - the plug-in is therefore found. Railclone behaves in exactly the same way. Please also note that it works with the altNetRenderCheck. So the plugin is loaded..

(....) the RenderNode reports: "There are not available License of RailClone in the License Server. Please contact ... " (same for Forest Pack) and freeze.
« Last Edit: September 30, 2021, 03:23:34 PM by visionsbox »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3842
    • iToo Software
Re: Mixed License/Installation use
« Reply #9 on: October 01, 2021, 08:53:52 AM »
We just completed our tests. As i suspected, "3dsmaxbatch.exe" (the new batch command in Max 2021/2022), has a different behaviour from "3dsmaxcmd.exe". It returns "false" for the function we use to detect render nodes.
I don't know if this is intentional or a bug, so we have reported the problem to Autodesk.

Meanwhile, the fix is to use altNetRenderCheck=1, as discussed in previous posts.

When Max runs on interactive mode, it creates a file Plugin.UserSettings.ini, which contains the path to the Max "plugins" folder (where Forest Pack & RailClone plug-ins are installed). In this way (the Max 2022 path may be different in your case):
[...]
It seems when Max is launched in some other way - like by Deadline in render mode, this file is not created, and plugins stored in the path are not loaded.
Sorry - but this didn't helped in my case. On the one hand, the file with the correct entry already exists in the target directory of the RenderUsers and, on the other hand, ForestPack already loads...

That's correct. The Plugin.UserSettings.ini issue seems specific to Deadline, and doesn't affect to Royal Render.

Carlos Quintero
iToo Software