Itoo Software Forum

Author Topic: Point Cloud Weirdness  (Read 679 times)

IJ2087

  • Jr. Member
  • **
  • Posts: 71
Point Cloud Weirdness
« on: March 09, 2018, 05:54:28 PM »
I just noticed an issue with the point cloud display on one of my RailClones. It shows geometry above and detached from the rest of the geometry. Any ideas on why this happens? 3 images attatched: Mesh, Box and PointCloud versions.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3328
    • iToo Software
Re: Point Cloud Weirdness
« Reply #1 on: March 12, 2018, 03:51:43 PM »
Hi, it seems a bug. Please, would you send us a simplificated scene ?

Thanks,
Carlos Quintero
iToo Software

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 890
    • iToo
Re: Point Cloud Weirdness
« Reply #2 on: March 12, 2018, 04:11:50 PM »
I too have PointCloud issue, saw it reported long time ago, thought You were working to fix it.
I attach my simplified scene.
Rokas
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3328
    • iToo Software
Re: Point Cloud Weirdness
« Reply #3 on: March 13, 2018, 09:30:52 AM »
I too have PointCloud issue, saw it reported long time ago, thought You were working to fix it.
I attach my simplified scene.

I think it's a different issue, although i would need to compare both scenes to be sure.

The problem in your scene is due to the limitations of point cloud in RailClone: some deformations are not computed along the full segment, but by "steps".
That is done by performance reasons. Although in this case the model is simple, in more complex objects the performance hit would be significative.

Carlos Quintero
iToo Software

IJ2087

  • Jr. Member
  • **
  • Posts: 71
Re: Point Cloud Weirdness
« Reply #4 on: March 13, 2018, 10:24:06 PM »
Hi, it seems a bug. Please, would you send us a simplificated scene ?

Thanks,

File sent. Sorry I didn't have time to send earlier.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3328
    • iToo Software
Re: Point Cloud Weirdness
« Reply #5 on: March 14, 2018, 04:44:55 PM »
Thanks for the scene.

We just noticed there is a bug with Z-Offset applied twice, for segments with "Bend" disabled. It will be fixed for the next update.
Carlos Quintero
iToo Software

IJ2087

  • Jr. Member
  • **
  • Posts: 71
Re: Point Cloud Weirdness
« Reply #6 on: March 14, 2018, 10:37:01 PM »
Thanks for the scene.

We just noticed there is a bug with Z-Offset applied twice, for segments with "Bend" disabled. It will be fixed for the next update.

Glad you found it!