Itoo Software Forum

Author Topic: Problem using 'use segment material'  (Read 173 times)

Pixual

  • Newbie
  • *
  • Posts: 8
Problem using 'use segment material'
« on: February 17, 2020, 10:19:24 AM »
I've stumbled upon a problem regarding adding an object to the Railclone library:

Short version of the problem:
When adding a new Railclone library object of a bunch of cars, 3DsMax crashes when trying to render the scene with V-Ray.

What i've tried:
- Update railclone, and V-ray to the latest version (didn't work, Max still crashes);
- Uncheck 'use segment materials' (partially worked, it renders the geometry just fine without the materials);
- Opened the source file (with all the 3D representation of the cars) (Renders fine, with materials, as long as the 3D geometry is in the file. When deleted or hidden, it crashes Max);

Any toughts what to do? I'd like to add it to the Railclone library for future use.

Thanks in advance!


Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2567
    • iToo
Re: Problem using 'use segment material'
« Reply #1 on: February 17, 2020, 10:33:54 AM »
Hi Pixual
Sorry to hear You got this problem.
I have just checked a simplified version of what You did and it seems to work as expected:



Would You please send us Your files that give You trouble and steps how to reproduce the crash. Thanks.
Rokas
iToo Software

Pixual

  • Newbie
  • *
  • Posts: 8
Re: Problem using 'use segment material'
« Reply #2 on: February 17, 2020, 11:02:29 AM »
Thanks Rokas for the quick reply!

I'll send the files to the helpdeks adress you provided using wetransfer. It contains the model, the bitmaps and the minidump file. If you need anything else, please let me know.

To recreate the issue i'm having:

1. Open the max file and start an interactive render using V-Ray, it will render just fine;
2. Simulating a railclone library file (where you just load the Railclone object, not the physical 3D objects) hide or remove the 3D objects, This will crash 3DsMax (it also does this when saved and loaded as an Railclone library object);
3. In addition to the above, when hiding or removing the actual 3D geometry of the cars and disabling the 'use segment material' in the Railclone modify tab, it renders the geometry fine, without materials.

I'd like to render the cars with materials, without having the actual 3D geometry in my scene (like a Railclone library object should work i guess).

Thanks again!