Itoo Software Forum

Author Topic: Railclone Curb Slab does not curb  (Read 139 times)

BB5945

  • Newbie
  • *
  • Posts: 6
Railclone Curb Slab does not curb
« on: November 24, 2021, 01:49:23 PM »
Hi all,

as you can see attached, something goes wrong with curb drop. Any idea to solve this issue ? Thank you in advance.

(This is the default "Concret Curb & Gutter" settings of RC library)

Best regards,
Nicolas
« Last Edit: November 24, 2021, 01:54:24 PM by BB5945 »

Dragan

  • Hero Member
  • *****
  • Posts: 881
Re: Railclone Curb Slab does not curb
« Reply #1 on: November 24, 2021, 01:54:18 PM »
Hi, check the value on the Style tab under the Curve Steps and try to increase it to about 60.

BB5945

  • Newbie
  • *
  • Posts: 6
Re: Railclone Curb Slab does not curb
« Reply #2 on: November 24, 2021, 02:10:58 PM »
Hi sir,

Thank you for your answer but It does not work :/
as you can see, the objects at the start and the end of the curb do not bend correctly....

Dragan

  • Hero Member
  • *****
  • Posts: 881
Re: Railclone Curb Slab does not curb
« Reply #3 on: November 24, 2021, 02:13:49 PM »
check is there a Vertex there and try to change it to Smooth.

BB5945

  • Newbie
  • *
  • Posts: 6
Re: Railclone Curb Slab does not curb
« Reply #4 on: November 24, 2021, 02:21:40 PM »
almost :)
and it changes the overall shape of the spline, that's not what I want

Dragan

  • Hero Member
  • *****
  • Posts: 881
Re: Railclone Curb Slab does not curb
« Reply #5 on: November 24, 2021, 02:23:05 PM »
Can you share the scene file and if you can downgrade it to Max2020

BB5945

  • Newbie
  • *
  • Posts: 6
Re: Railclone Curb Slab does not curb
« Reply #6 on: November 24, 2021, 02:28:39 PM »
In the style Editor, if I change "compose" parameter from Sequential to Grouped, the object bend correctly but it does a mess around

BB5945

  • Newbie
  • *
  • Posts: 6
Re: Railclone Curb Slab does not curb
« Reply #7 on: November 24, 2021, 02:31:31 PM »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2087
Re: Railclone Curb Slab does not curb
« Reply #8 on: November 24, 2021, 02:32:07 PM »
This issue is likely to be related to the thread here: https://forum.itoosoft.com/railclone-pro-(*)/drop-curb-problem-on-curved-line/

The drop kerbs have an issue on curved paths because of the way the spline is divided internally when using limit by material ID.

Ideally, we need to redo these using a different technique.

Paul
Paul Roberts
iToo Software

Dragan

  • Hero Member
  • *****
  • Posts: 881
Re: Railclone Curb Slab does not curb
« Reply #9 on: November 24, 2021, 02:51:12 PM »
Yes. You could go with a workaround to use Selector on MaterialID and go with one Generator.
I`m not sure if this is gona work  ;D ;D ;D
I didn`t check it at all. It was just a 15-second fix, but it will give you an idea of how to solve it.
« Last Edit: November 24, 2021, 03:04:06 PM by Dragan »

BB5945

  • Newbie
  • *
  • Posts: 6
Re: Railclone Curb Slab does not curb
« Reply #10 on: November 24, 2021, 03:01:25 PM »
Alright, thank you Dragan for your help !

and Paul thank you for sharing the file with the appropriate method !



Best regards,
Nicol