Itoo Software Forum

Author Topic: Railclone - Drop Curb Issue on Curved Spline  (Read 597 times)

II4889

  • Newbie
  • *
  • Posts: 1
Railclone - Drop Curb Issue on Curved Spline
« on: June 25, 2016, 12:17:33 AM »
Good day all,

First, I'm very new to Railclone. Modeling my first Arch Viz utilizing railclone and I'm running into an issue with the standard issue 'drop curb' being placed on a curved spline. Segment ID 2(s) are getting offset from the 'normal' curb for some reason and I can't for the life of me figure out why...

Any advice would be greatly appreciated.  Thanks in advanced!


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1551
Re: Railclone - Drop Curb Issue on Curved Spline
« Reply #1 on: June 27, 2016, 11:30:56 AM »
Hi,

Thanks for contacting us. Please see the attached file for a possible solution. The original version used a generator padding trick to allow me to use the Evenly input to create the joins between kerb stones, but unfortunately this causes problems on curved splines. I've fixed this in the attached file by removing the evenly input and using the Default > Adaptive mode, and using the compose operator to add the kerbs including their end caps to the Default input instead. This mode subtle scales the kerbs to ensure that only whole segments fit into the spline.

There is another approach that is slightly more complex and I would only recommend if this version still causes issues, you can read about it and download a sample file here: http://forum.itoosoft.com/index.php?topic=3109.msg12026#msg12026

I hope that helps out, please let me know if there's anything I can help further with.

Many thanks!

Paul.
Paul Roberts
iToo Software