Itoo Software Forum

Author Topic: Railclone requires a valid license  (Read 387 times)

iToo_Butler

  • Newbie
  • *
  • Posts: 44
    • DJS CGI
Railclone requires a valid license
« on: July 11, 2017, 10:27:13 AM »
Hi,

Just upgraded to Railclone 3.05b but now when I run Railclone i get a message saying "Railclone needs an updated license" and I need to "Please add to the license Manager the last code received with your software subscription. ALl was working well before the upgrade and all license codes are added in the license manager.

How can i fix this problem?

Andy.
Cheers,

iToo_Butler.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: Railclone requires a valid license
« Reply #1 on: July 11, 2017, 11:31:18 AM »
Hi Andy,

As the license server assigns licenses randomly from the available pool, regardless of its subscription state, you can get licenses errors if licenses with expired and active subscription plan are mixed on the license server. Would you mind to provide us screen-shots of the License Manager - Licenses tab and loaded Licenses Details (by using the Details... button) to analyse it here? Thanks in advance.

Best regards,

iToo_Butler

  • Newbie
  • *
  • Posts: 44
    • DJS CGI
Re: Railclone requires a valid license
« Reply #2 on: July 11, 2017, 12:22:08 PM »
Thanks for the reply.

There is a mixture of active and non-active licenses on there, but there has been for about 8 months so this issue has only happened since upgrading to 3.05b. Before I send you the screen grab, do you advise I remove the non active licences and only keep the active ones?

I'll give that a god anyway and see what happens.

regards


andy.

Cheers,

iToo_Butler.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: Railclone requires a valid license
« Reply #3 on: July 11, 2017, 12:28:20 PM »
Hi,

Most probably you've been using a version released during the "active" subscription plan period. Our licenses are perpetual - any of your licenses will never expire and you can continue using our products forever. In addition with the purchase of our plug-ins, we provide automatically one-year / three-years maintenance plan. Once the subscription plan expires, you are not able to use releases published after the subscription end date, but you still can use versions released before that date.

Don't feel obliged to update immediately your maintenance plan expire - if you'll be not using any new features and improvements there is no need to renew the subscription plan, as your "actual" version will remain working. Only if wanted, you can renew your subscription (at any time) and get access to latest upgrades.

Hope that clears it up.

Best regards,