Itoo Software Forum

Author Topic: RC extremely slow with Corona  (Read 453 times)

MrpepeLepeu

  • Newbie
  • *
  • Posts: 28
RC extremely slow with Corona
« on: June 18, 2019, 11:10:16 PM »
Hi.

I'm fairly new to RC.
I use Corona for rendering.

I find it extremely slow to work when rendering.
If I convert RC to mesh, then it's fine. Otherwise it takes several seconds to start rendering.

Is this how it's supposed to work?

Thanks.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2521
    • iToo
Re: RC extremely slow with Corona
« Reply #1 on: June 19, 2019, 07:57:00 AM »
Hi,

Sorry to hear you're facing these troubles. There should be no noticeable slowdown in most of the styles. It is probable on heavier meshes with disabled instancing.
If possible, feel free to send us your scene and we'll have a look at it here. Ideally, would you mind to try to reproduce the problem with a minimal scene and send us such a scene?

Thanks in advance for any further comments on this issue you can share about it with us / our user community.

Best regards,
Rokas
iToo Software

MrpepeLepeu

  • Newbie
  • *
  • Posts: 28
Re: RC extremely slow with Corona
« Reply #2 on: June 19, 2019, 05:28:42 PM »
I just sent you an email with subject "RC extremely slow with Corona".

I'm using Corona 4 and 3ds Max 2016.

More details: When you click on start IR it takes a while to start. If you convert RC to mesh, it starts instantaneously.

MrpepeLepeu

  • Newbie
  • *
  • Posts: 28
Re: RC extremely slow with Corona
« Reply #3 on: June 19, 2019, 06:08:11 PM »
Just FYI I have RC 3.3.1 installed.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: RC extremely slow with Corona
« Reply #4 on: June 20, 2019, 09:36:09 AM »
Hi,

Well, when using the Corona Renderer, in case of "Roofing styles", the Use Instancing Engine option is by default disabled because of Material / UVW XForm Operators are used and these are just partially supported (as you can see in the Feature Compatibility table) - to get these working correctly with the Corona Renderer, the Use Instancing Engine should be switched off.

Please feel free to turn the Use Instancing Engine option ON (attaching screen-shot) which will improve the performance, just take in mind that Material / UVW XForm Operators will have no effect on instanced geometry.

Best regards,