Itoo Software Forum

Author Topic: Roof tiles  (Read 1265 times)

Macker

  • Jr. Member
  • **
  • Posts: 91
Roof tiles
« on: January 05, 2017, 01:16:29 PM »
What is the best method for creating roof tiles?

These are the one's i'm looking to create https://www.marleyeternit.co.uk/~/media/Files/Product-Files/Roofing/Brochure-Request/Acme-Natural-Orange.pdf

See attached
« Last Edit: January 05, 2017, 01:20:23 PM by Macker »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1609
Re: Roof tiles
« Reply #1 on: January 05, 2017, 01:54:50 PM »
Hi,

The usual approach for a style like this is to use Clipping Splines coupled with Extend X/Y Size to Area.



This will automatically create an array that's large enough to fill the spline. Then all you need to do is create a closed spline for each roof elevation, align the RailClone object to the pitch of the roof and apply the spline. There's a handy script that can automate this part for you, you can get it here: http://forum.itoosoft.com/index.php?topic=2928.msg13321#msg13321

Regarding the style itself. Normally the offset would be created by alternating a standard tile and a "tile and a half" at the start and end of the array. You can do this by wiring them to a Sequence operator and setting it to Increment on Y.



I've attached a sample file showing these amendments. I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software

Macker

  • Jr. Member
  • **
  • Posts: 91
Re: Roof tiles
« Reply #2 on: January 05, 2017, 03:03:28 PM »
Hah, I knew there'd be a better way than how I'd gone about it! That's fantastic, thank you very much.

IN1264

  • Newbie
  • *
  • Posts: 1
Re: Roof tiles
« Reply #3 on: January 05, 2017, 06:07:12 PM »
Hi Paul,

I think I've encountered bug between my version of RailClone and yours.

I've made 2 gifs to demonstrate the problem:

1st gif I made in 3ds Max 2016 and 2nd was your file in 3ds Max 2017




On the first one (my object, created from scratch), when I resize the spline, the tiles are pushed to the right side, creating tiles that are cut and not perfect in size

On the second gif (your object), as I resize your spline, the tiles stay in the middle and thus resize perfectly.

When I use "Copy Style to" feature from your object to mine it works as it's supposed to.

So my question is - Is this a bug (I have the latest versions for both 2016 and 2017, but when I loaded your scene it said that your version might be newer) or is it some option I didn't apply?


« Last Edit: January 05, 2017, 06:23:12 PM by IN1264 »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1609
Re: Roof tiles
« Reply #4 on: January 05, 2017, 06:46:11 PM »
Hi,

To fix that you should just need to change your Deform mode to Adaptive.



This subtly rescales the default segments to make sure only whole tiles are used.

I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software