Itoo Software Forum

Author Topic: Rope vertex issue  (Read 609 times)

Cristero

  • Newbie
  • *
  • Posts: 22
Rope vertex issue
« on: May 28, 2015, 08:20:28 PM »
Hi guys. This time I want to ask if it's possible to solve a problem related to 3ds Max that involve the correctness of the RailClone object.
I've created a spline all around an object to simulate the effect of a rope, which works great till I leave the spline as it is. But when I'm trying to break the spline to insert a node at the intersection, even if I weld the vertices and Max is saying it's still a single spline, I get annoying artifacts as you can see in the images. It gives me that error with RailClone and with the "Enable in Viewport" spline tool as well.
I attach the images and the scene where you can also find a low poly model of the rope to build along the path.
Thanks.
« Last Edit: May 28, 2015, 08:25:31 PM by Cristero »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1538
Re: Rope vertex issue
« Reply #1 on: May 29, 2015, 09:12:40 AM »
Hi,

The step is being caused because the bottom of the rope is aligned to the path instead of the center. To fix this issue select the segment and change it's Properties > Alignment Z value to center.



I hope that helps, please let me know if you have further questions.

Many thanks,

Paul
« Last Edit: May 29, 2015, 09:16:21 AM by Paul Roberts »
Paul Roberts
iToo Software

Cristero

  • Newbie
  • *
  • Posts: 22
Re: Rope vertex issue
« Reply #2 on: May 29, 2015, 02:22:21 PM »
Thanks Paul for the answer. I managed to align the object as you did, but it works only with the cylinder. When I've tried to use the rope as a default RailClone object, the rope itself don't keep the path, even if bend is active. Have you tried it?
Thanks

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1538
Re: Rope vertex issue
« Reply #3 on: May 30, 2015, 10:04:56 AM »
Hi,

I see what's happening. Because the rope is higher poly than the cylinder, RailClone's adaptive display mode is kicking in to keep viewport performance fast. This mode replaces each segment with a box in the viewports only, it will render fine.



To deactivate adaptive display mode go to the Display rollout and turn on Viewport > Mesh. RailClone will now display the full geometry



You can read more about display modes here. I hope that  helps,

Many thanks,

Paul

Paul Roberts
iToo Software

Cristero

  • Newbie
  • *
  • Posts: 22
Re: Rope vertex issue
« Reply #4 on: May 30, 2015, 12:32:11 PM »
Thanks Paul, I knew about the Display modes, but didn't tried this time, because I thought it was a problem with the RailClone object.
Anyway, thanks for your help.