Itoo Software Forum

Author Topic: Rotation is not preserved when using groups as segments in RailClone 5  (Read 362 times)

Karax

  • Newbie
  • *
  • Posts: 7
Hi!

I am trying out the new features in RailClone 5 and I have a problem when using groups as segments. As shown in the attached screenshot, I have a couple of cubes grouped together to the left. To the right I have created a RailClone object which uses the group as its segment. The problem is that the rotation of the individual cubes is not preserved in the RC object. Is there a way to fix this?

« Last Edit: January 05, 2022, 11:43:30 PM by Karax »

Dragan

  • Hero Member
  • *****
  • Posts: 1295
Re: Rotation is not preserved when using groups as segments in RailClone 5
« Reply #1 on: January 05, 2022, 11:53:02 PM »
It is all about the pivots.
Check the pivots on individual boxes. Use Utilities>ResetXform>Reset Select
I`m not sure, but maybe you should ungroup>reset>group again


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4123
    • iToo Software
Re: Rotation is not preserved when using groups as segments in RailClone 5
« Reply #2 on: January 06, 2022, 10:09:19 AM »
Current implementation for groups support only translation, not rotation or scale. We'll improve it for next updates.
As Dragan pointed out, the workaround is Ungroup->Reset XForm->Group again.
Carlos Quintero
iToo Software

Karax

  • Newbie
  • *
  • Posts: 7
Re: Rotation is not preserved when using groups as segments in RailClone 5
« Reply #3 on: January 06, 2022, 12:07:42 PM »
Thanks a lot for the replies!
Great that you are planning to update this in upcoming versions! Until then I will use Dragan's method.