Itoo Software Forum

Author Topic: SME - really slow problem lag make me crasy  (Read 384 times)

IE6260

  • Newbie
  • *
  • Posts: 8
SME - really slow problem lag make me crasy
« on: November 16, 2022, 06:17:51 PM »
Hi,

state: I'm working with RC (5.2.6) to build a large factory racks configuration (like an amazon process)  with dynamic box contents that i can animatte by custom attribut on parent dummy. for case or for racks, i've a master style and other element are connected to this one.
Renderer : Corona 6 Hotfix 2
My material are a unique multisubobject node merging all elements to manage products and racks
(lot of viewports grab for details, also post in aswer to bypass x4 limit, sorry)

No problem for build, no problem for rendering, proxy work perfectly for non animate element and auto build work great work animated elements...


My problem is the materials and slate editor : opening slate editor is about 10 to 20 minutes long and it's make me crasy to select
another object that previous one ...
Maybe an idea : SME exposed a large quantiy of duplicate material ( image 09.jpg) and i don't know why because i only use myone to be sure of the organisation of submaterial and keep clear workflow to update ... (i've sed apply my material, all these duplicate ...)
removing all RC from scene make me working really really faster ....

Thanks by advance or for help



IE6260

  • Newbie
  • *
  • Posts: 8
Re: SME - really slow problem lag make me crasy
« Reply #1 on: November 16, 2022, 06:18:55 PM »
additionnal grabs

IE6260

  • Newbie
  • *
  • Posts: 8
Re: SME - really slow problem lag make me crasy
« Reply #2 on: November 16, 2022, 06:19:35 PM »
additionnal grabs

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Re: SME - really slow problem lag make me crasy
« Reply #3 on: November 17, 2022, 11:14:32 AM »
Hi,

Thanks for getting in touch. This seems like a very sophisticated setup and we don't have a lot of experience using wiring with RailClone on this scale. It might be helpful to send us the file to helpdesk@itoosoft.com so we can further try to understand where the bottleneck is.

Regarding the materials. That will probably happen if you make copies of a RailClone object where materials are assigned to the segment's source geometry. In that case, even if you replace the material on the railClone object itself, internally a copy is retained that was on the original segments. You can solve it by removing the material from the segments (if that's possible), or by reassigning the materials to the segments which should update all the related RC objects and remove the duplicates.

I hope that helps,

Paul
Paul Roberts
iToo Software

IE6260

  • Newbie
  • *
  • Posts: 8
Re: SME - really slow problem lag make me crasy
« Reply #4 on: November 17, 2022, 04:52:53 PM »
Hello,

Thanks for this first feedback.
Is there a way to fast select all segment sources in scene  ?
somethink like  for _rc in (for _o in objects where( classof _o == RailClone_Pro ) collect _o) collect _rc.segments ?

Thanks

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Re: SME - really slow problem lag make me crasy
« Reply #5 on: November 18, 2022, 05:42:41 PM »
Hi,

Please try the following

for _rc in (for _o in objects where( classof _o == RailClone_Pro ) collect _o) collect _rc.sobjnode

Cheers!

Paul
Paul Roberts
iToo Software

IE6260

  • Newbie
  • *
  • Posts: 8
Re: SME - really slow problem lag make me crasy
« Reply #6 on: November 24, 2022, 08:49:22 AM »
Hi,

just a little update of the mascript for next users if needed because _rc.sobjnode return an array so we got a 2Darray


_finalNodes=#()
_ndBase = for _rc in (for _o in objects where( classof _o == RailClone_Pro ) collect _o) collect _rc.sobjnode
for _e in _ndBase where ( _e != undefined) do (
   for _nd in _e where ( _nd != undefined) do (
      appendIfUnique _finalNodes _nd
   )
)
select _finalNodes

so _finalNodes is a 1D array containning only defined node


To remove material on all node :
_finalNodes.material = undefined

To verify result :
for _o in _finalNodes  do _finalNodes.material







IE6260

  • Newbie
  • *
  • Posts: 8
Re: SME - really slow problem lag make me crasy
« Reply #7 on: November 24, 2022, 08:59:11 AM »
And now the result on the test !  :-\

After removing all material from src node, i've save the scene, restart and reload scene. ...
it's a little bit faster but it's stay slowwwwww and i always have a large number of duplicate material (duplicate.png)

Material look's to be assign but i can get the holder, it's really strange. To do, i've rename one of the materials ("RailClone_PdxAndRack__Test") and run this script to find node :
for _o in objects where (_o.material != undefined ) do (
   if _o.material.name == "RailClone_PdxAndRack__Test" do print _o
)

And the result is empty .... how rc holding material, how can i clean it ?

Other question, i got a lot of information in the listner (listener.png), can i diseable message somewhere because 3dsmax is really the worth optimised software to print output messages ....  ::) :-X

Can you send me a private email to try send a 3dsmax scene ?

Thanks by advance

IE6260

  • Newbie
  • *
  • Posts: 8
Re: SME - really slow problem lag make me crasy
« Reply #8 on: December 07, 2022, 09:22:53 PM »
pas de news ?

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Re: SME - really slow problem lag make me crasy
« Reply #9 on: December 08, 2022, 09:58:20 AM »
Sorry for the slow reply,

Please feel free to send an email to helpdesk@itoosoft.com so that we can take a closer look.

Kindest regards,

Paul
Paul Roberts
iToo Software