Itoo Software Forum

Author Topic: UM Mapping elements  (Read 279 times)

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2150
    • iToo
Re: UM Mapping elements
« Reply #15 on: December 17, 2019, 06:01:04 PM »
That is an area to improve for RC. Unfortunately there is no fool proof solution. If UV mapping is crucial, then let RC build geometry, and UV that structure manually.
Rokas
iToo Software

enzo_87

  • Newbie
  • *
  • Posts: 19
    • www.lorenzospinola.com
Re: UM Mapping elements
« Reply #16 on: December 18, 2019, 04:45:59 PM »
I'm sorry to be painful,
but I can't find the right solution.

as said, I'm a rookie in max, so the process I'm doing it might be wrong.

-in general, I made the basic assets and I applied the materials and UW mapping modifier to have the right look in viewport.
in particular. I selected the mesh, applied the material and the uw mapping modifier.
I adjusted the setting to have the right look.
I applied an edit poly modifier, made another selection and applied the material.
I put the second uw mapping modifier and adjusted the orientation.

it looks fine in viewport, I haven't collapsed anything and the handrail and steps are looking fine.

-now I have the repetitions problem:
either that the box mapping is on or off, it looks the same.

-if I put vray in cpu mode, box mapping seems to work, buuuuuuut, it mess up the uw map orientation,
after that, I can't find a way to go back.
I tried to put back gpu mode, on/off box mapping...but nothing.

Am I doing something wrong since start?
should I do something different?

I can't understand how to manage the mapping projection correctly

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2150
    • iToo
Re: UM Mapping elements
« Reply #17 on: December 18, 2019, 04:56:34 PM »
I am not sure I fully understand Your issue, but RailClone can't do miracles with UVs, sadly.

I recommend reading more about UV in our documentation page.

Also i would recommend following tutorials from these pages:
http://docs.itoosoft.com/display/RAILCLONE/Getting+Started+with+RailClone
http://docs.itoosoft.com/display/RAILCLONE/Next+Steps+with+RailClone

They should give You solid understanding of how RailClone works (and why sometimes wont).
Rokas
iToo Software

enzo_87

  • Newbie
  • *
  • Posts: 19
    • www.lorenzospinola.com
Re: UM Mapping elements
« Reply #18 on: December 18, 2019, 05:04:03 PM »
I actually seen the getting started and the next steps, but they all start from objects premade with textures and materials already made.
I'm trying to figure out the process to work with RC from scratch.

the issue is:

-with vray gpu, orientation of the texture seems to work fine.
the only problem is the retetion that is not fixed with the box mapping

-switching to vray cpu, box mapping is working now, no more repetitions.
but on the other side, the orientation is now wrong, it has only one orientation.

-if I put back gpu mode, texture orientation still messed up, they don't go back.

it's ok that RC doesn't do miracle with uw...but I just want to know if the problem is me or not

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2150
    • iToo
Re: UM Mapping elements
« Reply #19 on: December 19, 2019, 08:35:06 AM »
Not all renders support native automatic uv mapping. Scanline and Vray GPU is among them.

RailClone sometimes do not refresh Geometry and textures after You do minor changes. Be sure to rebuild texture after You disable instancing engine when using vRay GPU:


Rokas
iToo Software

enzo_87

  • Newbie
  • *
  • Posts: 19
    • www.lorenzospinola.com
Re: UM Mapping elements
« Reply #20 on: December 19, 2019, 11:30:35 AM »
Good morning Rokas,
thanks so much for your help as always.

ok, vray gpus means no instances if I want the box mapping.
I was trying, it works, also the rebuild.

just one thing more:
basically, instances off, box mapping on.
the texture orientation change direction.
is this normal?
should I separate the mesh to avoid this?

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2150
    • iToo
Re: UM Mapping elements
« Reply #21 on: December 19, 2019, 11:38:38 AM »
Why box mapping on ?

seems this setup from above post is working well:


I dont want to tell You some magic settings. Please experiment and You will understand what settings works in what situations.
Rokas
iToo Software

enzo_87

  • Newbie
  • *
  • Posts: 19
    • www.lorenzospinola.com
Re: UM Mapping elements
« Reply #22 on: December 19, 2019, 11:50:39 AM »
Box mapping on because the texture repetitions are evident and I was tryong to remove them before to make the RC clone object as editable poly(that is the last chance).
when I turn on box mapping, with instances off for gpu, it mess everything up.

but yeah, as you suggested, I'll experiment more to undertand it better.

Thank for helping  :)
Lorenzo