Itoo Software Forum

Author Topic: Transparent Material  (Read 841 times)

GB2081

  • Newbie
  • *
  • Posts: 19
Transparent Material
« on: January 29, 2016, 09:56:10 AM »
Good morning!

I am currently facing an issue where I got stuck.
When I insert a custom built facade as a railclone object, the glass will not render transparent. The same scene has a simple 3dsMax box with exactly the same glassmaterial and renders correctly.
For better uderstanding, I attached a screenshot.

Where is my mistake? Would be great if someone could help me.
Thank you, Hari.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #1 on: January 29, 2016, 11:21:43 AM »
Hi,

Thanks for contacting us. I can't reproduce this problem here, would you mind sending me your file so I can take a closer look to ascertain what's going on? If you'd prefer not to share the files publicly please feel free to send it to support@itoosoft.com.

Many thanks!

Paul
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #2 on: January 29, 2016, 11:30:58 AM »
Thank you Paul for your quick response.
Here´s the file without material and HDRI.
The glass material should work, there´s no bitmap used.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #3 on: January 29, 2016, 12:37:59 PM »
Hi,

Thanks for the file. I've tested it here and it still appears to be behaving correctly.



But the wall object had an XRef material that I couldn't check. When I applied the glass material in the scene to the wall this is what I got. Are you sure the XRef material is the same?

Many thanks!

Paul
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #4 on: February 01, 2016, 04:17:25 PM »
Hi Paul

I just checked the material, it´s fine.

So this is what I did now:
I opended the original RC-library file of my glass facade and did a render directly in this file. - This works fine!
Then I created a new scene and imported exactly the same facade with the RC-tools. - No transparency!

Please see the attached image.
And I also attached the original RC facade file.

Thank´s for your help.
Harald

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #5 on: February 01, 2016, 04:50:09 PM »
Hi,

Are the materials saved in a separate .mat file? If so could you share the library with me too?. Ideally if you could send me the library's XML file or even zip the folder the contains the library and see me that it could be very helpful. I can't see a reason why this should happen. I've tested your file including importing it from the library and it all seems to work fine here.

Many thanks!

Paul
« Last Edit: February 01, 2016, 06:35:17 PM by Paul Roberts »
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #6 on: February 01, 2016, 05:20:10 PM »
Very strange.... ???

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #7 on: February 02, 2016, 11:28:22 AM »
Hi,

Thanks for the files, but I'm afraid I still can't reproduce the problem, I've also been discussing this with other members of the team and to our knowledge we haven't had any other reports of this issue. The odd thing is that RailClone doesn't affect the materials except that you can set the library to load a different material from a .mat file, which I can see from your XML isn't the case this time.

You can test to see if it's a RailClone issue by converting the the object to instanced meshes using RailClone tools. You can read about this here. If the problem persists after conversion then it's probably not related to RailClone as the object is now a standard mesh.

Also I can see also that you're using RailClone 2.3.4 and  I'm not sure which version of V-Ray but you could try installing the most recent versions. Though as I mentioned RC doesn't change materials so I'd be surprised if that's the problem.

Many thanks,

Paul
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #8 on: February 03, 2016, 10:00:01 AM »
Hi Paul, I just did another check.

I set up a scene and referenced the railclone library file to this scene.
Then I imported the same railclone object into my scene via rc-tools.

The referecned facade works fine, the railclone imported facade has no transparency.

I will keep on trying and finding out.
Hari.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #9 on: February 03, 2016, 10:28:43 AM »
Hi Hari, that's really strange.

It's definitely the same material on both objects? If you sample the material from the working RC object and apply it to the problem one does it still not work? Also when you say rc-tools can I just confirm that you mean the library browser. I can't imagine why this doesn't work.

Sorry about this issue, I hope we can get to the bottom of it.

Thanks,

Paul
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #10 on: February 03, 2016, 11:02:52 AM »
OK, I somehow got stuck.
But I found out, that it´s an issue with the multimaterial of rc objects.

Both renderings show an xref facade of the original rc library file in the background.
And both images show a rc-imported facade in the foreground.

Image 1
The objects of the rc library file use a single glass material. -> Transparency is fine

Image 2
The objects of the rc library file use a multimaterial where exactly the same glass material is part of it. -> Transparency is wrong. But only in the rc imported object.

That´s a bit annoying.
But maybe we find a solution

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #11 on: February 03, 2016, 11:18:24 AM »
Could I ask which version of V-Ray you are using so I can try to reproduce the same conditions here. Am I correct in thinking that you're using RailClone 2.3.4?

Thanks!
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #12 on: February 03, 2016, 12:04:58 PM »
Hi Paul, I´m using RC Pro 2.3.4 and Vray 3.00.03

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Transparent Material
« Reply #13 on: February 03, 2016, 01:49:15 PM »
Hi,

Could you send me a single scene in which contains both the correct and incorrect versions or the RC object.

Thanks!

Paul
Paul Roberts
iToo Software

GB2081

  • Newbie
  • *
  • Posts: 19
Re: Transparent Material
« Reply #14 on: February 03, 2016, 02:38:15 PM »
Ok, here we are:

I uploaded an archive file.
Please open the "iTOO_HDRI_Exterior.max" File. There you will find one xrefed file. (No HDRI included)

"iToo_PR-Fassade.max" is my xrefed railclone library file. It contains 2 rc objects. The left one uses multimaterial, the right one has a single glass material which is exactly the same, used in multimaterial on the left.

When rendering, both xrefed facades appear transparant. But when I bring in the railclone objects into my "iTOO_HDRI_Exterior.max" (objects in the middle), only the non multimaterial works.

I hope I could describe it clearly.
Thanks.