Itoo Software Forum

Author Topic: Unwanted gaps being made in pattern  (Read 1158 times)

Hayes Davidson

  • Newbie
  • *
  • Posts: 10
Unwanted gaps being made in pattern
« on: October 02, 2014, 01:28:56 PM »
Hi

I'm creating a cobble pattern using railclone, which is generally working really well, but it seems to be having problems on the more intricate section in the middle creating gaps/holes in the pattern.  I've had a search on the forums and tried increasing the curve steps up to 1000 with no change, as well as trying to make the first vertex in the spline a corner (rather than a bezier), again with no change.

Could anybody shed some light on how to fix this?  I'd prefer not to have to do this manually!

Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Unwanted gaps being made in pattern
« Reply #1 on: October 02, 2014, 02:18:56 PM »
It seems some bug with the clipping algorithm. Please, would you send us the scene to support@itoosoft.com ?. We'll check it.

If the problem is caused by clipping, you would create the object with RailClone and cut it using booleans. At least while we investigate this issue.
Carlos Quintero
iToo Software

Hayes Davidson

  • Newbie
  • *
  • Posts: 10
Re: Unwanted gaps being made in pattern
« Reply #2 on: October 02, 2014, 03:42:09 PM »
Thanks for the quick response.  I have emailed the scene file as requested.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Unwanted gaps being made in pattern
« Reply #3 on: October 02, 2014, 05:53:09 PM »
Thanks for the scene. I can confirm it's a clipping bug with this specific area.
We'll work to fix it, but probably this may take some time. Meanwhile, i suggest you use the boolean method, as described in my previous post.

I apologize by the inconveniences.
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Unwanted gaps being made in pattern
« Reply #4 on: October 03, 2014, 12:12:16 PM »
After some debugging, we have isolated the problem in the boolean Max algorithm (which RailClone uses internally for clipping). It seems a precision numeric error because the scene's units.

There is a more simple workaround:

1) Reset and set Units Setup->System Unit Setup to mm.
2) Load scene and select Rescale the File Objects to the System Unit Scale.
3) Clipping should be correct now. Collapse RC to editable mesh and merge it in your main scene.

I hope that helps. Unfortunately we cannot fix the problem in RailClone, because is caused by Max booleans.
Carlos Quintero
iToo Software

Hayes Davidson

  • Newbie
  • *
  • Posts: 10
Re: Unwanted gaps being made in pattern
« Reply #5 on: October 07, 2014, 11:05:10 AM »
Ah I see.  Thank you for taking the time to look into this and for the quick response and solution.

George

  • Full Member
  • ***
  • Posts: 120
Re: Unwanted gaps being made in pattern
« Reply #6 on: October 08, 2014, 04:00:13 AM »
I've had something similar, and it was resolved by increasing the expand %  a little, but when it comes down to it Carlos is right - the Max boolean stuff is very dependent on scene scale.