Itoo Software Forum

Author Topic: UVW XForm - UV's coordinates problem  (Read 924 times)

trimitek

  • Newbie
  • *
  • Posts: 27
    • My models @ TurboSquid
UVW XForm - UV's coordinates problem
« on: September 21, 2017, 02:07:12 PM »
Hi there,

I'm making a mosaic that uses pieces of a single big texture and randomize the UV coordinates with UVW XForm operator.
I need to convert the mosaic to editable poly, but when i add UVW Unwrap modifier I can see that the UV's are miles away from the UV 0-1 space and from each other.

Is there a way (or a script) that can move the UV's in the 0-1 UV space, without messing the position (the part of the texture they cover) and the scale of the pieces?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: UVW XForm - UV's coordinates problem
« Reply #1 on: September 21, 2017, 05:50:05 PM »
Hi,

It sounds like, you've entered high values (over 1). Attaching screen-shots showing a possible set-up whene all randomized mapping takes place inside of the 0-1 UV space.

Best regards,

trimitek

  • Newbie
  • *
  • Posts: 27
    • My models @ TurboSquid
Re: UVW XForm - UV's coordinates problem
« Reply #2 on: September 21, 2017, 06:23:44 PM »
Hmm, I am using different approach.
I put larger box mapping on a small mosaic piece (I don't change the fixed tile setting (leaving it at 1)) and just use the random offset values.

If I have to use your approach I have to set the fixed tile value to 0.055555, but its limited to two digits after the . (I have 90x90cm texture size and 5x5cm mosaic pieces)

trimitek

  • Newbie
  • *
  • Posts: 27
    • My models @ TurboSquid
Re: UVW XForm - UV's coordinates problem
« Reply #3 on: September 21, 2017, 06:40:38 PM »
Attaching some screenshots: