Itoo Software Forum

Author Topic: VRAY Next Update 1 + Roof Tiles = Bug?  (Read 763 times)

suppenhuhn

  • Jr. Member
  • **
  • Posts: 97
VRAY Next Update 1 + Roof Tiles = Bug?
« on: December 06, 2018, 01:40:09 PM »
Hi!
I got a strange error since i made the Update 1 for VRAY Next.

When attaching RailClone Rooftiles presets to a spline ( see screenshot / two separate splines ) the LightCache Build takes forever - when attaching my own RailClone Rooftiles made with the Rooftilesmacro everything is fine.

I did not have any problems with this before VRAY Next Update 1 - except the spline vertices weren't accurate.
« Last Edit: December 06, 2018, 01:46:24 PM by suppenhuhn »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2515
    • iToo
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #1 on: December 06, 2018, 01:50:36 PM »
Hi,

It is hard to identify the problem from this screenshot.
Please attach or send it to us it so we can see where the problem is.
Rokas
iToo Software

suppenhuhn

  • Jr. Member
  • **
  • Posts: 97
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #2 on: December 06, 2018, 02:01:35 PM »
Guess i've found the reason:

The splines got more vertices than just the corners ( see screenshot ) - made them with your awesome boundary-script provided with a former tutorial.

After removing the vertices between it's working with the rooftiles presets as well ! Prior the update i didn't remove those extra vertices.
« Last Edit: December 06, 2018, 02:04:22 PM by suppenhuhn »

suppenhuhn

  • Jr. Member
  • **
  • Posts: 97
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #3 on: March 14, 2019, 10:02:48 AM »
Sorry, but i have to restart this thread because the problem occurs again  :-\
I've attached the file causing that error. I'm using MAX 2015 & latest versions of VRAY / Railclone.

Short History using h_roof_1a as the spline for railclone rooftiles:
  • h_roof_1a was created -> lightcache build takes forever error
  • h_roof_1a spline -> edit spline -> ( the outline ) spline reverse -> no error
  • h_roof_1a spline -> edit spline -> attach h_roof_1b ->  lightcache build takes forever error
  • h_roof_1a spline -> edit spline -> detach h_roof_1b again -> lightcache build takes forever error

Hope it helps a little...

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #4 on: March 14, 2019, 02:39:13 PM »
Hi Rob,

Big thanks for reporting this problem and providing the scene. With your help, we've been able to reproduce this unwanted behavior here too and we'll see what can be done to fix it - it'll need to be investigated more in deep by our main developers. Meanwhile, the Style > Operate On > Polygons mode seems not to suffer this issue (instead of the Triangles).

Best regards,

suppenhuhn

  • Jr. Member
  • **
  • Posts: 97
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #5 on: March 15, 2019, 10:29:21 AM »
Thank you for your response - i'm no able to test it but i'll try as soon i got my hands back on my PC !

Maybe also interesting for you: This problem occures with the Railclone Roof-Presets.

Using my own tiles with the roof-tiles-macro there is no error ( as far as i remember )

Coffeeholic

  • Newbie
  • *
  • Posts: 5
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #6 on: April 29, 2019, 02:31:12 PM »
Hi I found this thread after searching and just wanted to report I'm having the same issue, I'm working on a development with over 50 buildings and when I go over 5 or 6 roofs using any preset light cache gets stuck forever.

I also tried changing all the roofs to operate on polygons but the problem remains.

Waiting anxiously on a fix. Thanks!

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2515
    • iToo
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #7 on: April 29, 2019, 03:36:32 PM »
Please attach Your scene so we can inspect it and offer a solution.
Rokas
iToo Software

jedchambers

  • Newbie
  • *
  • Posts: 2
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #8 on: August 05, 2019, 04:38:51 AM »
Im having the same issue too.

Is there a fix for this yet?
« Last Edit: August 05, 2019, 04:44:35 AM by jedchambers »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2515
    • iToo
Re: VRAY Next Update 1 + Roof Tiles = Bug?
« Reply #9 on: August 05, 2019, 05:38:57 AM »
Hi.
If Changing to "polygon mode" does not fix the issue, please send us Your scene max file so we can check it.

Rokas
iToo Software