Itoo Software Forum

Author Topic: Material Randomisation no working on Straight Spline Segments  (Read 443 times)

JM2145

  • Newbie
  • *
  • Posts: 22
Material Randomisation no working on Straight Spline Segments
« on: February 26, 2019, 11:08:49 PM »
Hi

As you can see in the screenshot, my material randomisation isn't working on areas of spline that are straight?

It's a very basic Linear Array, with 7 different segments.

The material is a simple diffuse map, plugged into a Corona Multimap to get the variation.

Why does it only work on the curved sections of spline?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: Material Randomisation no working on Straight Spline Segments
« Reply #1 on: February 27, 2019, 10:41:00 AM »
Hi,

To get the Material Operator working correctly with the Corona Renderer, the Use Instancing Engine option should be switched off - some features are "fully supported" only in case of the V-Ray render engine (as you can see in the Feature Compatibility table, for the rest of renderers it can be enabled by turning off the instancing engine). Use of features like Material / UVW XForm Operators are just partially supported.

Best regards,

JM2145

  • Newbie
  • *
  • Posts: 22
Re: Material Randomisation no working on Straight Spline Segments
« Reply #2 on: February 27, 2019, 02:19:04 PM »
I'm not using a material operator.

It's simply a Corona Multimap in the shader

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: Material Randomisation no working on Straight Spline Segments
« Reply #3 on: February 27, 2019, 02:49:21 PM »
Hi,

For the Corona MultiMap usage together with RailClone applies the same and upon my quick test with the Mesh Element Mode, switching off the Use Instancing Engine feature fixes it.

Best regards,