Itoo Software Forum

Author Topic: Xref scene bug and $.upgradeFromVersion(275) fix  (Read 1440 times)

Pixelab

  • Jr. Member
  • **
  • Posts: 78
  • Suave mari magno
    • pixelab.be
Xref scene bug and $.upgradeFromVersion(275) fix
« on: May 03, 2018, 11:01:28 AM »
We ran into strange behaviour of Railclone, our workflow is based on a Master MAX file (2016) RC 3.0.7  with multiple Xref Scenes, one containing 30+ railclone objects (roofs, etc.)

The renders started acting strangly, sometimes fine, sometimes freezing on a bucket (CPU usage stops) or freezing in the middle of LC calculation or just crashing when loading (pipe has ended 106 error). No RAM issue (plenty of unused RAM) disabling instancing engine did not help.

This is linked to RC because when we hide the roofs layers, everything is fine.

I found this fix in the last relase and it seems related (I've meanwhile updated to 3.10):

Quote
Fixed: objects created with RC2 are not upgraded to RC3 when using XRef scenes.
* This problem occurs in the main scene, not in the XRef'd one.
* Once saved with RC3, failed objects cannot be fixed even loading them with this patch. To help with that, we added a Maxscript function to fix them manually. Just select one by one, and run: $.upgradeFromVersion(275)

Some of our roofs are using the last improvements (they're great btw :) but have $.createdVersion = 307

Some older objects have been createdversion values like 247, 234 etc.

My questions :

- Does running the command $.upgradeFromVersion(275) will fix all the older objects, or do I have to change the command according to the RC object : e.g. $.upgradeFromVersion(247)

- Is it likely to fix the strange render behaviour ?

- Is it a way to mass edit all the objects ?

Scene is very complex, difficult to share. But if needed I can send an archive to support.

thx !!
« Last Edit: May 03, 2018, 11:38:23 AM by Pixelab »

Pixelab

  • Jr. Member
  • **
  • Posts: 78
  • Suave mari magno
    • pixelab.be
Re: Xref scene bug and $.upgradeFromVersion(275) fix
« Reply #1 on: May 03, 2018, 11:42:50 AM »
Just made a test after running the command on all the objects.

Looked better but freezed again in the middle of the render.

Aerial view (with obviously all the roofs visible) freeze in the middle of the LC

Is there a way to list/ display all the .createdversion of all the object ? I would be tremendously useful to debug these kind of scenes.

I'm not against redrawing/ recreating a corrupted RC object but not 30 objects without knowing if it would be useful.


Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2514
    • iToo
Re: Xref scene bug and $.upgradeFromVersion(275) fix
« Reply #2 on: May 03, 2018, 11:51:29 AM »
for obj in geometry do if (classof obj == RailClone_Pro) then print (Obj.name +": " +obj.createdversion as string)
Rokas
iToo Software

Pixelab

  • Jr. Member
  • **
  • Posts: 78
  • Suave mari magno
    • pixelab.be
Re: Xref scene bug and $.upgradeFromVersion(275) fix
« Reply #3 on: May 03, 2018, 11:54:54 AM »
for obj in geometry do if (classof obj == RailClone_Pro) then print (Obj.name +": " +obj.createdversion as string)

Awesome ! thx

Pixelab

  • Jr. Member
  • **
  • Posts: 78
  • Suave mari magno
    • pixelab.be
Re: Xref scene bug and $.upgradeFromVersion(275) fix
« Reply #4 on: May 03, 2018, 12:48:02 PM »
Thanks to the script line, I finally recreated all the RC object one by one (with copy style from icon)

All the objects are now version 310 and ... it works !

An answer to my first post would be nice for other stumbling into the problem, I have the feeling that starting on a clean slate somtimes sends old bugs down the drain without havin got find & fix them.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2514
    • iToo
Re: Xref scene bug and $.upgradeFromVersion(275) fix
« Reply #5 on: May 03, 2018, 01:40:42 PM »
I am glad You found what worked for You and shared it with us. I believe this will be useful for some users down the road.
Rokas
iToo Software