Itoo Software Forum

Author Topic: problem creating guardrail  (Read 2398 times)

LB2304

  • Newbie
  • *
  • Posts: 19
problem creating guardrail
« on: July 11, 2011, 09:54:59 PM »
I'm having a bit of difficulty making a guardrail tile properly.  The spacing is such that there are gaps in the rail that shouldn't be there.  Any help would be appreciated, thanks!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3316
    • iToo Software
Re: problem creating guardrail
« Reply #1 on: July 11, 2011, 11:38:17 PM »
Ok, i have done the following changes:

- The objects are aligned with the X axis, also i have created a test spline in the same direction (i feel more comfortable creating the RailClone object this way).
- The pivot point of the rail is aligned to left side, and centered for the post. In this way, the default segment always starts with the spline, and the post is centered for corners and evenly positions. I also have adjusted boths pivots properly in the Y and Z axis.
- The rail object is added to the RailClone object as 'middle' segment, and the post as 'evenly'.
- To remove the gap between rails, i have defined a negative padding for the post segment (-0.5 / -0.5). The exact values are not important, always that the sum of both is greater than the post's width. In this way, the width of the post seen by RailClone is zero, so the rails to the left and right side to the post are joined.
- I have shortened the rail object a bit. The exact lenght is not important, because RailClone creates all clones needed to fit the full spline, but using shorter segments you will get smoother objects on curves.
- Finally, although i have not included it, you would enable Randomness->Mappping for the rail segment, to minimize the texture tiling.

« Last Edit: July 11, 2011, 11:42:06 PM by Itoo »
Carlos Quintero
iToo Software

LB2304

  • Newbie
  • *
  • Posts: 19
Re: problem creating guardrail
« Reply #2 on: July 12, 2011, 12:14:36 AM »
brilliant, thanks a lot!  I was playing with the pivot points for all the objects, but only in the x axis.  Thanks for the speedy reply!