Itoo Software Forum

Author Topic: urbanPark tutorial  (Read 2388 times)

LE3462

  • Newbie
  • *
  • Posts: 2
urbanPark tutorial
« on: May 22, 2012, 05:20:48 AM »
I couldn't help but notice the road geometry in the "urban park" tutorial. It appeared to be made of several segments; kinda like what railclone was made for. It will be nice to see a tutorial of how this roads (with the white lines) where made using railclone.... Perhaps a tutorial of the tutorial. ;)

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: urbanPark tutorial
« Reply #1 on: May 22, 2012, 08:36:07 AM »

We used an internal tool to create it, but it can be done using several RailClone Lite objects as well:

- Create a plane for the stripe.
- Assign it as "Evenly" segment, and set the separation using the "Distance" parameter.
- For the continuous line, you can use the same stripe as "Default" segment, or use a "Sweep" modifier directly over the spline.
- Once assigned to the splines, would be needed to adjust the subdivisions (X axis) of the stripe object, so it bend properly at curves.

Carlos Quintero
iToo Software

LE3462

  • Newbie
  • *
  • Posts: 2
Re: urbanPark tutorial
« Reply #2 on: May 22, 2012, 12:21:00 PM »
Will try it out. What about the road itself. They look like segments as well and it may become tricky at road intersections.... Will railclone work for that as well.

 And also how do you get the stripes to show and render properly over the road as they occupy the same space and could result in coplanar surfaces. ..... And if you modify the z axis of one or the other you get a slight shadow line between the planes.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: urbanPark tutorial
« Reply #3 on: May 22, 2012, 01:14:40 PM »

We used the same procedure for the roads (using a wider segment). But the joints are adjusted manually, there is not a specific tool for it.

The stripes have a tiny Z offset applied (1 cm. or so), so the shadow is not visible. Anyway, you can turn off "Cast Shadows" on them (right click->Object properties) to avoid that problem.

Carlos Quintero
iToo Software