Itoo Software Forum

Author Topic: RC object from Window tutorial is not aligning correctly  (Read 647 times)

DamianM

  • Newbie
  • *
  • Posts: 8
    • MONSUMM
RC object from Window tutorial is not aligning correctly
« on: April 18, 2017, 11:54:10 AM »
Hello,

I have big problem with windows, when You open my file You can see that my object have Inner and outer frames in separate Array 2S generator. When I pin it to spline inner frames are not built correctly with multiple different budg.

Can You also tell me how can I set style so I can set  angle of opened inner frames vertically prom 0 do 90 degrees using Numeric parameter ?
 

I have also suggestion to RailCloneSlicer v01 You could add option to slice geometry as Reference so we can easily edit main geometry and effect will be added to our sliced objects.

I also suggest to add option like "scale" in "Clipping arena -> For No-slice" so the last of first segment will be scaled to end exactly when border is and slice option should have "cap" option.
« Last Edit: April 18, 2017, 01:08:26 PM by DamianM »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1492
Re: RC object from Window tutorial is not aligning correctly
« Reply #1 on: April 18, 2017, 07:00:47 PM »
Hi,

Thanks for the feedback and the file. I've attached a revised version that I think fixes a few of the issues you encountered. I've made the following changes:

- Changed Clipping Area > Auto Align to X => XY for all generators. This will align the windows so that they're always upright.
- Changed Clipping Area > Hierachy Checking to None. This will ensure each spline generates a window. In Complete mode splines that overlap can interfere with one another
- Turned off Slice for a few segments. I'm not sure why but the geometry was being clipped incorectly for a few segments, I'll look into this.
- Changed Generator Y and Z Offset. This is important and is probably what was causing issues. Currently the generator's Z and Y Offset axis are aligned to the RailClone object's axis, ideally it should be aligned to the arrays axis. We will need to make some changes on our side to make this happen, but in the meantime you can use the segment's transform settings instead.
- Made a few changes to padding to ensure that segments on the left of the array had only left padding and segments on the right of the array had only right padding.

Regarding openable windows. This is currently tricky but I'm working on a macro that might be able to help out. I need to iron out some kinks but hopefully it will be in a future version of RC3 beta.

There's already a macro that scales the final segment to prevent slicing, it's in the Transform category and there's one for each axis named Scale Final Segment X and Scale Final Segment Y

I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software

DamianM

  • Newbie
  • *
  • Posts: 8
    • MONSUMM
Re: RC object from Window tutorial is not aligning correctly
« Reply #2 on: April 19, 2017, 06:15:47 PM »
Thank You very much for help and explanation !

Have a nice day !