Itoo Software Forum

Author Topic: Update Manager Error 04: We can't verify the download  (Read 2450 times)

Scott Dombrowski

  • Newbie
  • *
  • Posts: 3
Update Manager Error 04: We can't verify the download
« on: July 08, 2017, 06:44:13 PM »
I'm attempting to deploy RailClone to our render nodes.  The first part of the install goes fine, but when the Update Manager tries to update the packages, I get "Error 04: We can't verify the download of the Macros RailClone".  A few weeks ago I installed 3.0.4b on my main workstation and Update Manager ran fine.  Now when I run the Update Manager on my main workstation, I see one package available (Exterior Railings), but am unable to install it because I get the same Error 04.  I checked with IT and they didn't see anything in their logs that indicated something got stopped by antivirus.

Any ideas?

Pablo

  • Newbie
  • *
  • Posts: 25
Re: Update Manager Error 04: We can't verify the download
« Reply #1 on: July 10, 2017, 09:46:54 AM »
Hi there,

- Can you attach us the update manager log? You can find it  at "C:\Users\<USERNAME>\AppData\Local\Itoo Software\Update Manager\update.log"
- Please, replace UpdateManager.exe in C:\Program Files (x86)\Itoo Software\RailClone Pro, with the version attached to this post

If it doesn't work, I would suggest you to "reset the Update Manager" by deleting the following registry key (using "regedit.exe"):

HKEY_CURRENT_USER\SOFTWARE\Itoo Software\Update Manager\Packages

Alternatively, use the attached .reg (open the zip and double click the .reg file). Thanks in advance for any further comments on this issue you can share about it with us / our user community (in case some user(s) will run into similar troubles).

Greetings, Pablo :)

« Last Edit: July 17, 2017, 01:08:30 PM by pabloFM »

Scott Dombrowski

  • Newbie
  • *
  • Posts: 3
Re: Update Manager Error 04: We can't verify the download
« Reply #2 on: July 10, 2017, 12:42:12 PM »
Hi there,

- Can you attach us the update manager log? You can find it  at "C:\Users\<USERNAME>\AppData\Local\Itoo Software\Update Manager\update.log"
- Please, replace UpdateManager.exe in C:\Program Files (x86)\Itoo Software\RailClone Pro, with the version attached to this post

Attached is the update.log, though it seems you already knew what the issue was, because the new .exe did the trick.  It works now.  Thanks for the quick response!

I realize that RC3 is in beta, but since I'm on Max 2018, that's what I must use.  Do you have a deployment method that deals with the Update Manager so I don't have to enter my account credentials on each render node?

Thanks again!

zules

  • Newbie
  • *
  • Posts: 28
Re: Update Manager Error 04: We can't verify the download
« Reply #3 on: June 13, 2018, 03:20:51 PM »
Hello,
i'm getting the same Error04 on Max 2016 with FPP 6.0.9.

I used the regedit file but getting 2 new errors :
- with the updatemanager.exe you give here, missing QtCore4.dll
- with reinstalling FPP 6.0.9, installer error 0x000007b when trying to install updatemanager.exe

Hope this help

FC1888

  • Jr. Member
  • **
  • Posts: 94
Re: Update Manager Error 04: We can't verify the download
« Reply #4 on: June 14, 2018, 01:31:00 AM »
I use Max 2014, just so you know and I got the same error "can't verfy the download......"

I just cancelled it, then ran Update Manager later, after the install of FP 6.0.9 completed and everything was fine. Obviously an error popping up is not a good sign, but far as I can tell it's all good after re-running Update Manager