Itoo Software Forum

Forest Pack => Tutorials => Topic started by: Paul Roberts on November 11, 2015, 02:13:42 PM

Title: Parking Cars with Forest Pack
Post by: Paul Roberts on November 11, 2015, 02:13:42 PM
Post here your questions and comments about the Parking Cars with Forest Pack tutorial.
Title: Re: Parking Cars with Forest Pack
Post by: daredyoshi on November 11, 2015, 03:52:23 PM
very nice. How would I animate the traffic cars? As far as I can tell these are just static...like this it would seem that even the potential for creating still images is limited to ones with a very high shutter speed where you don't notice that the cars are not moving because of motion blur.
Title: Re: Parking Cars with Forest Pack
Post by: Paul Roberts on November 11, 2015, 05:09:35 PM
Hi,

If you want to just add a bit of forward animation to simulate motion blur then this is possible but you must animate the source geometry (the car) and then convert it to a Proxy object. Here's the steps you'd follow to do this:


(http://i.imgur.com/VMOI9CH.png)
This was tested with the new Forest Pack 5.0 beta.

Obviously this won't allow you to create complex driving animations but for adding some simple motion blur it works fine.

I hope that helps, please let me know if you have any further questions.

Many thanks!

Paul
Title: Re: Parking Cars with Forest Pack
Post by: dbhinnant on November 12, 2015, 01:33:49 PM
Thank you for the tutorial.  I had been using Civil View to place parked cars but the randomization options here are great.  It would be awesome if you could write a traffic plugin for animation.  The only options out there for us are not very well supported.  Your support and constant updates are among the best I've seen for 3ds Max plugins.

I am having difficulty with the color randomization.  At first it seemed to be working, but now I am getting all cars being one color.  I am using Mental Ray so I had to interpolate from the tutorial.  I am also using the Civil View cars which are aXYZ vehicles.  They have multiple sub-object slots that are used for color randomization.  Any ideas what I could have done wrong?
Title: Re: Parking Cars with Forest Pack
Post by: Paul Roberts on November 12, 2015, 02:14:39 PM
Hi,

Thanks for the kind words. Colour randomisation should work the same in Mental Ray as in V-Ray. Would you be able to send me a simplified scene of what you have so I can take a closer look? I'f you prefer not to post a link here, please send to support@itoosoft.com.

Many thanks!

Paul
Title: Re: Parking Cars with Forest Pack
Post by: dbhinnant on November 12, 2015, 02:54:08 PM
I downloaded your Mental Ray files for the tutorial and duplicated your texture.  It seems to be working now.  Thanks.
Title: Re: Parking Cars with Forest Pack
Post by: Paul Roberts on November 12, 2015, 04:39:07 PM
Glad to hear you've found a solution, let me know if I can help with anything else.

Cheers,

Paul
Title: Re: Parking Cars with Forest Pack
Post by: jshulters on December 21, 2015, 10:43:43 PM
Hi Paul. I was super excited to see the "official" parking tutorial with some clarifications that improved my own workflow quite a bit (I'm still trying to automate a bit more based on CAD parking lines that are already provided by the client so I don't have to do the added step of creating distribution lines...but your solution was pretty easy considering the old way of doing things). The random car paint colors using Forest map was great...took me a bit more time to tweak my library, but it's worth it.

Regarding the vehicle materials, I created a preset for a standard parking lot after I got everything working following your tutorial, but when I went to apply that preset to a new project, the car materials were all messed up (metal tires, non-transparent glass, way-off paint colors), so something obviously was getting mismatched between the individual car materials and the forest material. I checked the Material slot in the Geometry rollout and everything seemed to be assigned correctly, but I could click the assigned material and see there were two instances of each in the scene (one on the Forest001 object itself, and one on a hidden object on the forest_templates layer). When I clicked "Clear" above the Geometry>Material slot, everything magically went back to the way it should be and renders correctly. However, the Material slot for each object is empty.

I don't want to mess around with it much more since it seems to be working, but does this issue make any sense to you? It's one minor extra step to assign the Forest Pack preset and then select all the Geometry items and Clear their Material, but it seems like that shouldn't be needed. Is it possible I created my preset incorrectly? I can send example files if needed.

Thanks!
John

Title: Re: Parking Cars with Forest Pack
Post by: 3D Digital Studio on May 06, 2016, 02:30:45 PM
Hi Paul,
Thanks for your car park tutorial it has been really useful.
I was just experienting with using railclone to create the carpark road markings and Forest park for the Car and I wanted to use the same spline for both but I can not align them.
I have attached a max file , but it has seperate splines for  them.
I was wondering if you can tell me if i am doing anything wrong?

Thanks for your help
Title: Re: Parking Cars with Forest Pack
Post by: IH3888 on December 19, 2017, 11:52:22 AM
Hello there!
I've got a problem with this file : car_park_end_vray downloaded from this link : https://www.itoosoft.com/download.php/forest_tutorial_car_park_vray (https://www.itoosoft.com/download.php/forest_tutorial_car_park_vray)

When i click (see attached picture) create, after modifying the spline named : spline_overpass the scattering of the cars disappear...

Is it normal ?

i'm working with :
Title: Re: Parking Cars with Forest Pack
Post by: Paul Roberts on December 19, 2017, 12:32:33 PM
Hi,

With those settings all existing cars will be removed and new cars will be places only on vertices. If you wish to retain the existing cars, make sure that Delete Existing Items is unchecked. If you wish to rebuild new cars along the spline, you need to change the mode to Spacing.

I hope that helps.

All the best,

Paul
Title: Re: Parking Cars with Forest Pack
Post by: IH3888 on December 19, 2017, 02:26:54 PM
I succeed to scatter.
But... Although all cars have their pivot in the right place, when i create : a big number of the cars (More than the half of cars) are in the wrong way ? I need to rotate them  to put them in the good way... About the pivot, i use the pivot of the maserati as reference.
Title: Re: Parking Cars with Forest Pack
Post by: PGD on August 16, 2018, 01:14:42 PM
I'm struggling to do do this with version 6 - where is the Use spline button now or is this done another way now?
Title: Re: Parking Cars with Forest Pack
Post by: Rokas on August 16, 2018, 03:53:03 PM
Spline mode is now moved to Distribution rollout:
(https://i.imgur.com/QvXglBR.png)
Title: Re: Parking Cars with Forest Pack
Post by: PGD on August 16, 2018, 04:21:13 PM
Thanks for that.

With that used, the cars now sit on the spline, but don't reference the selected surface, so they float in mid air. How do I reference the spline AND surface?

I have a car park which isn't level you see.
Title: Re: Parking Cars with Forest Pack
Post by: Rokas on August 16, 2018, 07:18:11 PM
You can still add surface as well.
(https://i.imgur.com/SPt8x5F.png)
Title: Re: Parking Cars with Forest Pack
Post by: Josh on September 06, 2018, 04:16:28 PM
Hello,

This is a great tool! There does seem to be a problem though, the markers can become truncated at the ends of splines, and when this happens the marker will be made with two faces. When you add the cars using forest, two cars will appear and one of them will have an incorrect rotation. Unfortunately, there is no collision detection when using reference objects.
Is there a way to get the RC not slicing the ends off the markers?


J.
Title: Re: Parking Cars with Forest Pack
Post by: Rokas on September 06, 2018, 05:04:00 PM
Please use marker of triangle shape- I could not replicate the issue- it worked great for me:
(https://i.imgur.com/Vyg8cWO.gif)
Title: Re: Parking Cars with Forest Pack
Post by: Josh on September 06, 2018, 05:18:32 PM
Hello Rokas,

Thanks so much for looking into it! I am using the scene file downloaded from the tutorial page, and it has an embedded triangle shape in the RC Style. All I did was to adjust the car spacing until some become sliced.

HOWEVER - I have solved the issue by changing the mode of the default segment to adaptive under rules on the array nodes.

Best,

J.
Title: Re: Parking Cars with Forest Pack
Post by: Rokas on September 07, 2018, 06:54:45 AM
Thanks for the tip!
Title: Re: Parking Cars with Forest Pack
Post by: LittleAnimator on August 21, 2019, 03:47:08 PM
Don't know if its something I've missed but when I use the flip cars in horizontal mirroring, the cars licence plates end up the wrong way round and the drivers side swaps too. Anyone know how to flip the cars randomly without it changing the texture/model?
Title: Re: Parking Cars with Forest Pack
Post by: Rokas on August 21, 2019, 04:47:02 PM
Don't know if its something I've missed but when I use the flip cars in horizontal mirroring, the cars licence plates end up the wrong way round and the drivers side swaps too. Anyone know how to flip the cars randomly without it changing the texture/model?
This behavior of "horizontal mirroring" is exactly what You described. It may not be the best option for cars, but for foliage it adds another step of randomness.