Itoo Software Forum

Author Topic: Scattering on Vertical Surfaces  (Read 1554 times)

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Scattering on Vertical Surfaces
« on: October 05, 2016, 10:37:45 AM »
Post here your questions and comments about the Scattering on Vertical Surfaces tutorial.
Paul Roberts
iToo Software

Rokas

  • Sr. Member
  • ****
  • Posts: 402
Re: Scattering on Vertical Surfaces
« Reply #1 on: October 05, 2016, 01:28:38 PM »
Thank You.

P.S.
Wrong link in vimeo video description.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: Scattering on Vertical Surfaces
« Reply #2 on: October 05, 2016, 02:52:49 PM »
Thanks Rokas. Fixed!
Paul Roberts
iToo Software

theedge

  • Newbie
  • *
  • Posts: 31
Edge mode not working
« Reply #3 on: January 12, 2017, 07:38:23 AM »
Hi,

I am trying to apply this technique to simple planar walls, so no UV mode used.
The scattering itself works.
I then need to limit it to a boundary, but the Edge mode doesn't work. According to the tutorial it should :
Quote
Let's start by taking a look at how to scatter of vertical planar areas, which has the advantage of retaining all of Forest Features including edge mode, spline painting and more.
I set it up as I would for any FP : add the spline to the Areas list, deactivate the Surface Area and check "Edge" in Boundary Checking. Is there anyhting else to ado when dealing with a vertical surface ?

Thank you.

entretesmains

  • Newbie
  • *
  • Posts: 3
Re: Scattering on Vertical Surfaces
« Reply #4 on: January 12, 2017, 10:19:40 AM »
Hi everyone!
I'm trying to put my itoo forest on the walls of my room, but the scattering remains on the floor even with the pivot changed to fit the normals of the walls. I can align the forest object with the pivot so it sticks to the walls but whenever i change one single parameter in the edit mode, the proxies dissapear...
I've really no idea of how to do...
Thank you
Here's an image of my room : http://imgur.com/HQma4An

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1385
Re: Scattering on Vertical Surfaces
« Reply #5 on: January 12, 2017, 10:40:07 AM »
Hi,

It sounds like, you're using the XY mode and your surface coordinates doesn't correspond with intended Forest object orientation (for example a plane created in front view will work differently with Forest objects as another one created in Perspective / Top view).

To cover all parts of your object I would suggest you to use the UV mode instead (using UV coordinates instead of XY projection). Please feel free to check our on-line reference guide for more detailed info. As mentioned there: "The UV mode uses the mapping coordinates of the surface as alignment guide for the Distribution map. This mode is best used on rough terrains or to scatter items over convex 3D objects (as a sphere). Note that using this mode, the UV coordinates must be precisely defined to get a coherent result."

Hope that helps.

Best regards,

entretesmains

  • Newbie
  • *
  • Posts: 3
Re: Scattering on Vertical Surfaces
« Reply #6 on: January 12, 2017, 05:20:14 PM »
Thank you so much it helped a lot indeed!
But now I'm facing another problem, my mesh (here in foreground : http://imgur.com/a/kQGkF) axis don't adapt to the walls uv. I mean it should scatter 90° from the walls but here it just stays vertical... I read the tutorial you gave me but it says "When "Scale to fit" is enabled, the Direction value is fixed to 0 (Normal aligned). This feature is not used on UV mode." Since I'm in uv mode I'm a bit lost.

Thank you for your time!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1385
Re: Scattering on Vertical Surfaces
« Reply #7 on: January 12, 2017, 05:31:17 PM »
Hi,

You're welcome. Though the Scale to fit sloped areas option isn't available, it's still possible to change the Direction value - setting it to Normal (0) should fix it.

Best regadrs,

entretesmains

  • Newbie
  • *
  • Posts: 3
Re: Scattering on Vertical Surfaces
« Reply #8 on: January 12, 2017, 07:15:38 PM »
It worked! Thanks for the fast feedback!