RailClone > Work in Progress

Escalator Library dooesn't work


Good morning guys

Recently we purchase the pack of Railclone & Forestpack and my surprise was that firs thing I am using and it doesn't work.  :-[
I have a spline following my reference from Revit and after creating the Railclone Object and pick the Escalator solid doble, and applied the spline in to the spline node. The stairs appear like turned up.
I tried to modify de options from Style Editor (big mess, It will be grateful if in future versions the nodes are more organized and not overlapped each other.)

I Tried to rotate the Step02 node that looks like control the direction of the stair. But I cannot control, I don’t know yet how it works Railclone.

Can anyone help me to figure out?
I am doing something wrong?



Thanks for contacting iToo Software and for your confidence in our plug-ins.

I'm sorry to hear, you're facing these troubles. The way how the Selector Operator handles out of range values changed a bit. We'll check what can be done to avoid this unwanted behavior (rework affected bundled styles). Meanwhile, to fix it (besides of directly using the modified version attached):

    Add 1 to the boolean value using an Arithmetic operator.
    Swap the order of the segments wired to the Selector operator.

Unfortunately, there are more styles affected by this change in the Selector Operator and we'll try to publish these changes soon. As we are pretty busy these days with other pending tasks, I'm afraid I can't give you a time frame when that might happen. Thanks for your comprehension.

I'm attaching these "updated" escalators styles files - please overwrite your local copy (by default located under C:\Users\<yourUsername>\AppData\Local\Itoo Software\RailClone Pro\lib\default1\Architecture\Interior\Escalators\objects) with these.

In case of any further question(s) or doubt(s), please don't hesitate to contact us. Have a nice day.

Best regards,


[0] Message Index

Go to full version