Itoo Software Forum

Author Topic: gInstalling the xfrog catalog.  (Read 6246 times)

iToo_Butler

  • Newbie
  • *
  • Posts: 44
    • DJS CGI
gInstalling the xfrog catalog.
« on: August 06, 2013, 10:12:31 AM »
Hi all.

I've read through the FAQ and and searched the forum but i can't find the answer to my problem!

I have downloaded and installed the Xfrog catalog but when i navigate to the folder where the library is installed i have a window popping up saying the directory doesn't contain the specific library.

How can i get this to work? Is it looking for a specific file somewhere?
Cheers,

iToo_Butler.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: gInstalling the xfrog catalog.
« Reply #1 on: August 06, 2013, 10:27:56 AM »
XFrogCatalog uses a specific file for each library, to check if the files are available or not. These files are listed at C:\Program Files (x86)\Itoo Software\XFrogPlants Catalog\lib\xfrogplants.ms:

global xfrogdef = #(
        #("X-18","XFrogPlants Africa","\Models\AF01_Acacia_tortilis_Umbrella_Acacia\AF01a.max",""),
        #("X-55","XFrogPlants Agriculture","\AG01_Avena_sativa_Oats\AG01_1.max",""),
        #("X-01","XFrogPlants Autumn","\Models\AL01_Acer_Palmatum_Japanese_Maple\AL01a.max",""),
        #("X-48","XFrogPlants Asia","\AS01_Bambusa_vulgaris_Golden_Bamboo\AS01_1.max",""),
        #("X-02","XFrogPlants Basic","\Models\BL01_Aesculus_hippocastanum_Horse_Chestnut\BL01a.max",""),
        #("X-19","XFrogPlants Bonsai","\Models\BN01_Acer_campestre_Field_Maple\BN01a.max",""),
        #("X-03","XFrogPlants Blossoming","\Models\BS01_Cercis_siliquastrum_Judas_Tree\BS01a.max",""),
        #("X-14","XFrogPlants USA Conifers","\Models\CL01_Abies_concolor_White_Fir\CL01a.max",""),
        #("X-15","XFrogPlants USA East","\Models\EA01_Acer_rubrum_Red_Maple\EA01a.max",""),
      #("X-16","XFrogPlants USA West","\Models\WE01_Abies_grandis_Grand_Fir\WE01a.max",""),
        #("X-04","XFrogPlants Europe 1","\Models\EU01_Acer_campestre_Field_Maple\EU01a.max",""),
        #("X-05","XFrogPlants Europe 2","\Models\EU21_Abies_alba_Silver_Fir\EU21a.max",""),
        #("X-44","XFrogPlants Europe 3","\EU41_Acer_cappadocicum_Cappadocian_Maple\EU41_1.max",""),
        #("X-06","XFrogPlants Flowers 1","\Models\FL01_Anthurium_andraeanum_Flamingo_Lily\FL01_1.max",""),
        #("X-07","XFrogPlants Flowers 2","\Models\FL21_Agapanthus_campanulatus_Bell_Agapanthus\FL21_1.max",""),
        #("X-45","XFrogPlants Flowers 3","\FL41_Antirrhinum_sp_Snapdragon\FL41_1.max",""),
        #("X-08","XFrogPlants Fruit","\Models\FR01_Carica_papaya_Papaya\FR01a.max",""),
        #("X-09","XFrogPlants Groundcover","\Models\GC01_Achillea_millefolium_Common_Yarrow\GC01_1.max",""),
        #("X-56","XFrogPlants Home Garden","\HG01_Allium_cepa_Onion\VG01_1.max",""),
        #("X-10","XFrogPlants Houseplants","\Models\HP01_Aeschynanthus_ssp_Mona_Lisa\HP01_1.max",""),
        #("X-11","XFrogPlants Japan","\Models\JA01_Abies_homolepis_Nikko_Fir\JA01a.max",""),
        #("X-60","XFrogPlants Landscaping","\LS01_Acer_platanoides\LS01_01.max",""),
        #("X-12","XFrogPlants Mediterranean","\Models\ML01_Cedrus_atlantica_Atlas_Cedar\ML01a.max",""),
        #("X-57","XFrogPlants Oceania 1","\OC01_Acacia_dealbata_Silver_Wattle\OC01_1.max",""),
        #("X-58","XFrogPlants Oceania 2","\OC21_Acacia_aneura_True_Mulga\OC21_1.max",""),
        #("X-59","XFrogPlants Oceania 3","\OC41_Acacia_sophorae_Coastal_Wattle\OC41_1.max",""),
        #("X-22","XFrogPlants Prehistoric","\Models\PR01_Alethopteris_serli\PR01a.max",""),
        #("X-20","XFrogPlants Shrubs","\Models\SH01_Carpinus_betulus\SH01_1.max",""),
        #("X-17","XFrogPlants USA Southwest","\Models\SW01_Agave_americana_Century_Plant\SW01_1.max",""),
        #("X-13","XFrogPlants Tropical","\Models\TR01_Anacardium_occidentale_Cashew\TR01a.max","")
        );


Please, check if the file exists for the library you are using. If not, would be necessary to make some changes in the XFrogCatalog scripts.

To create the catalog, we used the directory structure of the current XFrog libraries (downloadable version), but i'm not sure if they changed this format on the past.
Carlos Quintero
iToo Software

iToo_Butler

  • Newbie
  • *
  • Posts: 44
    • DJS CGI
Re: gInstalling the xfrog catalog.
« Reply #2 on: August 06, 2013, 11:41:12 AM »
Great, thanks for the reply. I've noticed my folder structure was slightly different but have fixed this issue.

I copied the .ms file in to where my xfrog models were installed and it works but I have another question.

How can i change to location that xfrog is looking for a library? I now have the Africa set looking for the library in a different location to all the rest as i was using this library to do my tests to get the catalog to work.

Secondly, it seems that you have to link each library one at a time. Is there a way to do this once, so all Xfrog libraries get found easily. I'm using 3dsmax so something like the asset manager where you can change more than one path at once would be handy!


« Last Edit: August 06, 2013, 12:22:36 PM by iToo_Butler »
Cheers,

iToo_Butler.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: gInstalling the xfrog catalog.
« Reply #3 on: August 06, 2013, 08:50:09 PM »
The paths configuration is stored in the following registry key:

HKEY_CURRENT_USER\Software\Itoo Software\Forest Pack Pro\LibraryMacros


i.e.: x-18_path = E:\lib\xfrog\XfrogPlants_Africa_MAX

Currently there is not any option in Forest to edit these values, but you can modify the registry directly. All paths are reset when reinstalling XFrogCatalog, so also would be a good idea backup it in a .reg file, if you want to preserve the configuration.
Carlos Quintero
iToo Software

Karax

  • Newbie
  • *
  • Posts: 5
Re: gInstalling the xfrog catalog.
« Reply #4 on: September 10, 2013, 12:23:40 PM »
Hi

I´m kind of experiencing the same problem. Alla the libraries work fine for me except for Europe 3-2. xfrog catalog just refuses to accept its location. I noticed it´s not in the xfrogplants.ms list and in its lib I noticed it´s reffering to x-44 so I copied the library to the same folder as 3-1. No success =(. I even tried adding a value manually, calling it x-46 in the registry, xfrogplants.ms and lib but that didn´t work either. Any suggestions?

/Kristian

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: gInstalling the xfrog catalog.
« Reply #5 on: September 10, 2013, 12:48:42 PM »
You are right. In this case it was our fault: Europe 3-2 is not included in the script. This should be the missing line:

#("X-44b","XFrogPlants Europe 3-2","\EU51_Platanus_orientalis_Oriental_Planetree\EU51_1.max",""),

Please, replace the file C:\Program Files (x86)\Itoo Software\XFrogPlants Catalog\lib\xfrogplants.ms with the attached one. That should fix the problem.
Carlos Quintero
iToo Software

Karax

  • Newbie
  • *
  • Posts: 5
Re: gInstalling the xfrog catalog.
« Reply #6 on: February 25, 2014, 02:04:43 PM »
A bit late but thanks a lot!

TM3598

  • Newbie
  • *
  • Posts: 42
Re: gInstalling the xfrog catalog.
« Reply #7 on: June 18, 2015, 10:50:16 AM »
Hi,

I know I need this fix but I don't understand it.

In my case, I keep Maps and Models separate, so for me my models are kept in;

eg. L:\3DS MAX Libraries\3D Models\foliage\Xfrog\XfrogPlants_Africa

And my maps are kept in;

L:\3DS Max Libraries\Maps\Xfrog

(I put all of the entire Xfrog maps into on directory as your other set of Xfrog guidelines suggested - using your handy script).

Now I know where the .ms script is (i.e.  C:\Program Files (x86)\Itoo Software\XFrogPlants Catalog\lib\xfrogplants.ms)

- but I don't know what I need to do to this ?

For example, do I need to change each line that looks like;

#("X-18","XFrogPlants Africa","\Models\AF01_Acacia_tortilis_Umbrella_Acacia\AF01a.max",""), 

If so, what do I change, and using my paths as an example (for models and maps) what do I change and what to ?

Do I change \Models\ to L:\3DS MAX Libraries\3D Models\foliage\Xfrog\ ??

Also, you mention editing the registry, so is this where I make the change also ?

I'm confused.  Do I change the .ms, or the registry, or both ?


I've taken a look in the registry area you mention and so far, there are no entries in there for xfrog (only my ones for HQ Plants).  Is that because, at this point in time, xfrog hasn't been set up yet via that xfrogplants.ms script ??  (up until now I've only ran the xfrog catalog installer).

Thank you for your assistance.



« Last Edit: June 18, 2015, 11:01:46 AM by TM3598 »

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: gInstalling the xfrog catalog.
« Reply #8 on: June 18, 2015, 01:08:38 PM »
Hi,

Actually, there is no need to edit the maxsript file (xfrogplants.ms) nor system registry. Just take in mind, that the Library Browser is looking for original folder structure after unpacking. Therefore, when unpacking any of Xfrog libraries, you should leave its folder structure as it is (it should be unpacked with its full folder structure).

Under the Select installation Path you should select the "parent" folder - in case of Africa it should be the XfrogPlants_Africa_MAX folder (in your case L:\3DS MAX Libraries\3D Models\foliage\Xfrog\XfrogPlants_Africa) and so on. This way you can map your paths to models easily.

The path to your maps location should be mapped under Customize->Configure User Paths->External Files (in your case to L:\3DS Max Libraries\Maps\Xfrog).

Hope that helps. Also let me mention, that we published few days ago a brand new "Creating Libraries" tutorial covering related "libraries" topic in detail. You might find it interesting.

Best regards,

TM3598

  • Newbie
  • *
  • Posts: 42
Re: gInstalling the xfrog catalog.
« Reply #9 on: June 19, 2015, 01:15:27 PM »
Hi Michal,

And thanks for your reply (I didn't receive an email notification telling me I'd received one).

Yes, I'm fine now, xfrog works for me and you're right, that Creating Libraries tutorial was exactly what I needed to watch :)

Many thanks.

BE4297

  • Newbie
  • *
  • Posts: 2
Re: gInstalling the xfrog catalog.
« Reply #10 on: July 21, 2015, 10:36:32 PM »
Guys i ve all the xfrog dvd version 2 or 3 for Oceania but i really don t know how to put in the forset pack library, it say to me there is not library in the path, please tell me the structure to get it cause i tryed to follow the steps in the tutoprial for the HQ but i think is different. It s not working. Please Help

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: gInstalling the xfrog catalog.
« Reply #11 on: July 23, 2015, 01:26:40 PM »
Hi,

As memtioned above, "the Library Browser is looking for original folder structure after unpacking. Therefore, when unpacking any of Xfrog libraries, you should leave its folder structure as it is (it should be unpacked with its full folder structure)."

Under the Select installation Path you should select the XfrogPlants_Oceania_2_MAX folder (XfrogPlants_Oceania_3_MAX respectively).

Best regards,

BE4297

  • Newbie
  • *
  • Posts: 2
Re: gInstalling the xfrog catalog.
« Reply #12 on: July 24, 2015, 11:08:21 PM »
Ok it s working thanks