Itoo Software Forum

Author Topic: Forest 2D planes and Z Passes  (Read 4501 times)

jona

  • Newbie
  • *
  • Posts: 32
Forest 2D planes and Z Passes
« on: September 27, 2011, 08:08:04 PM »
When I set up Z passes for my renders, forest planes show up as transparent in the Z passes. So. If I have a hill with trees on it the hill will show the proper z info but any trees will show up as transparent.

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: Forest 2D planes and Z Passes
« Reply #1 on: September 28, 2011, 08:21:26 AM »
What version of 3dsmax and render engine did you use ? Could you send more information about your scene and setup, also some image or snapshot of the problem will be helpful to us.

Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

jona

  • Newbie
  • *
  • Posts: 32
Re: Forest 2D planes and Z Passes
« Reply #2 on: September 28, 2011, 05:25:23 PM »
3dsmax 2011- Mental Ray.

If you just set up a plane and place some 2D trees on it, then render a z pass you will notice the trees are transparent.

I will try to get a frame posted today.

Thanks!

jona

  • Newbie
  • *
  • Posts: 32
Re: Forest 2D planes and Z Passes
« Reply #3 on: September 28, 2011, 05:59:05 PM »
here is a targa still from the render. Notice the white below the trees and the gray behind the trees. That is a long plane representing a field and background hills. the trees are at the front of the plane so the areas just below the trees show the front portion of the plane and the gray area is the rear. THe trees are in the white area yet  they render transparent. most of the time I can fix this with a white plane behind the frame in my comps. I just wanted to let you know about this in case it is a fix you can put in the next release.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Forest 2D planes and Z Passes
« Reply #4 on: September 29, 2011, 10:34:00 AM »

Sorry, but i can't see yet the problem. The lower half of your image is black, i don't know if the transparent trees should be there, of if the targe file is clipped.

I just created a test scene for Max 2011. It includes a long plane with some palms, the Z pass is enabled in render elements, and the result seems correct. Please, if possible try to reproduce the problem here.

Thanks,

Carlos Quintero
iToo Software

jona

  • Newbie
  • *
  • Posts: 32
Re: Forest 2D planes and Z Passes
« Reply #5 on: September 29, 2011, 04:42:29 PM »
I tried your file and it did yield proper Z in Max's VFB. Though if you load that file into a compositor you get the same thing I saw in my project.
 
Here is a frame from another project. This is what I typically see.
I have also included the targa output from your project which has the same problem.

I am rendering to targa files with alpha channels. the problem does go away if I render without an alpha channel.. so maybe I have to just do that.

oh.. yes.. my images are all rendered at gamma 2.2. In case you view the color pass I sent earlier again.
« Last Edit: September 30, 2011, 04:55:38 AM by jona »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Forest 2D planes and Z Passes
« Reply #6 on: September 30, 2011, 09:43:13 AM »

Yes, now i can reproduce it rendering to targa with alpha.

But it seems a Max bug with the opacity maps. The problem is the same converting Forest to an editable mesh + standard material. By some reason the Z pass changes if the alpha channel is enabled.

Carlos Quintero
iToo Software

jona

  • Newbie
  • *
  • Posts: 32
Re: Forest 2D planes and Z Passes
« Reply #7 on: September 30, 2011, 03:31:44 PM »
well.. that's interesting. I don't doubt it.

I started thinking the same thing last night.

The trick is to render without an alpha channel or ignore it in my compositor. So sorry for putting you through that test. Hate to waste anyone's time. I should have done that test myself before posting.

Thank you for checking that out.