Itoo Software Forum

Author Topic: Problem with 2D Tree Shadows  (Read 312 times)

Edwin

  • Newbie
  • *
  • Posts: 2
Problem with 2D Tree Shadows
« on: March 27, 2018, 05:11:42 PM »
Hi,
I am using Forest Lite. When I render with scanline Ray Tracing on the 2D trees using fake shadows, some of the shadows are "split". I have attached an image. Can anyone tell me how to fix this problem? Thanks.
-Edwin

Edwin

  • Newbie
  • *
  • Posts: 2
Re: Problem with 2D Tree Shadows
« Reply #1 on: March 27, 2018, 06:27:26 PM »
Hi,
I looked at the problem and figured I could just hack the tree shadows (see attached image). Here's how:
1. Turn off fake shadows, just let the raytracer in 3DS Max create the shadows.
2. Modify the camera parameters of the forest object. Make the single-plane tree billboards follow the camera.
3. Create a copy of the forest object. Leave it at the same position in the scene as the original forest object.
4. Modify the camera parameters of the new forest object. Clear out the camera settings and make the tree billboards follow the light, not the camera.
5. In 3DS Max, modify the general properties of the original forest object. Turn off "cast shadows". Then modify the general properties of forest object #2 and turn off "visible to camera".
6. This works great, and you get nice ray traced shadows no matter how the light source is oriented. But of course you need to create forest object #2 late in the design process since it won't automatically update if you change the tree layout...
-Ed

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3245
    • iToo Software
Re: Problem with 2D Tree Shadows
« Reply #2 on: March 29, 2018, 09:46:40 AM »
Hi, have you assigned the raytrace light in the Shadows rollout ?

Forest creates automatically the geometry to cast shadows. These "shadow planes" exist only for the light, and are not visible on render.

The process to use fake shadows should be the following:

1) Be sure the Camera is assigned in the Camera rollout, and "Look-At" checkbox is enabled.
2) Assign the light in Shadows->Raytrace->Light.
3) Double check your materials are using "Forest Material" as base (you can check the materials included in the library for reference).

You can find here an (old) tutorial describing the process.

Carlos Quintero
iToo Software