Itoo Software Forum

Author Topic: All the Tree A were missing in some frames after a long time render. Why?  (Read 1466 times)

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Hi iToosoft,
Some strange problem happened when I rendering a large area of my Forest.
1. I was making a large area of forest with some kinds of Trees. The animated samples trees are all in Xmesh Format. Then I sent the scene to backburner.
All the path of render sequences of Xmesh objects were network driver mapping paths of the main render node of the backburner. I was sure that no file missing in rendering in all render node.
For example, there were tree A,B and C in my forest objects. They were all in random sample animation mode. The forest objects were all in manual update display mode. The trees were very high poly Xmesh objects.
I always use the point detection mode in my forest.
After a long long time render I found all the "Tree A" were missing in some frames ! It was not some of the tree A were missing but all the tree A were missing in the same frames. But all the tree B and the tree C always appeared accurately.
I've no idea why this happen after my long time render in backburner now. Please help me.

2. Another problem is, why I must always keep the "Keep Mesh in Memory" be checked in the Xmesh loader menu otherwise I can't render the forest in backburner. "Keep Mesh in Memory" will almost eat up my memory.

MAX2012 64bit  FP 4.2.4 VR 2.40
Please help me. Best wishes.
« Last Edit: February 20, 2015, 08:05:02 AM by cc8boy »
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: All the Tree A were missing in some frames after a long time render. Why?
« Reply #1 on: February 20, 2015, 04:18:33 PM »
Hi,

Well, the problem is most probably related to having the "Random Samples" animation mode selected. As commented on another related thread some time ago:

"We have found that XMeshLoader could produce issues when used in combination with Random Samples animation mode."

Unfortunately, we can't do much more in this case as we have no influence of how the XMeshLoader treats the geometry. We strongly advice to use the "Follow Geometry" animation mode if any of XMeshLoader object(s) is used. If needed several items with adjusted Frame Offset can be used. Actually, that's probably the best workaround.

Regarding the need of having marked the "Keep Mesh in Memory" option for XMeshLoader object used with Forest Pack for network rendering handled by Backburner:

As documented on Thinkbox Software site: "Keep Mesh in Memory - Keeps the current frame's geometry in memory, so the XMesh Loader wouldn't reread the data from disk when updated. If unchecked, the file will be read each time an update happens (which can be useful if the files are being constantly updated from another copy of 3ds Max, for example)."

Actually, in our tests it works fine even without having this option marked (tested with XMeshLoader 1.3.0.55681). If possible, please send us the simplified scene (containing problematic Forest object(s)) through WeTransfer to support@itoosoft.com to analyse it here. Thanks in advance.

Kind regards,

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: All the Tree A were missing in some frames after a long time render. Why?
« Reply #2 on: February 20, 2015, 06:43:08 PM »
Finally, May I ask a question? Are you sure there won't be any problem if I convert all the Xmeshloader into Vrayproxies ? I must use the random Samples animation mode.
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: All the Tree A were missing in some frames after a long time render. Why?
« Reply #3 on: February 21, 2015, 05:31:34 PM »
We can't be sure without trying it, but similar problems has not been reported with proxies or other animated formats.

XMesh uses a very particular format, i guess that optimized to generate a specific animation sample (at the current time of the XMesh object). It doesn't work well with the random sample mode, because Forest needs samples at different times, and XMesh is not designed for that.
Carlos Quintero
iToo Software

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: All the Tree A were missing in some frames after a long time render. Why?
« Reply #4 on: February 21, 2015, 10:30:48 PM »
Anyway, can you tell me what kind of caching model system is most suitable for Forest pro pack ?
The two very imprtant things are,
1.The changing topology models must be cached with this caching system.
2.It's best that the color of the elements in the caching object can be changed by Forest color in this caching system. (change color by elements not objects)

I'm looking forward to you answer.
« Last Edit: February 22, 2015, 08:58:34 AM by cc8boy »
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: All the Tree A were missing in some frames after a long time render. Why?
« Reply #5 on: February 24, 2015, 01:46:23 PM »
Hi,

There are several animation caching tools for 3ds Max, but in most of them, the own internal data interpolation could cause problems with the Random Samples animation mode as mentioned before (like in case of XMesh).

As dynamic topology meshes are not supported by Point Cache, I would suggest you to use the Alembic data format (with support of dynamic topology meshes). To 3ds Max this data format was introduces recently (specifically in 3ds Max 2015 Extension 1), but there are also another options working for previous 3ds Max versions.

As you can see from attached screenshots, the Random Samples animation mode works fine with VRayProxies, but the functionality of Forest Color map is limited. Instead Alembic data format supports fully the Forest Color funcionality.

For our tests we used Exocortex Crate, the Alembic suite of tools for 3DS Max, that is now open source.

Hope that helps.

Best regards,

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: All the Tree A were missing in some frames after a long time render. Why?
« Reply #6 on: February 26, 2015, 10:49:55 AM »
Thanks for your reply. I tried Exocortex Crate the Alembic suite before I use Xmesh(model exported from SpeedTree). The Alembic data format is good, but It will generate a super huge .abc file. It's a big challenge sending these data in my network, so does the Vrayproxies. Because of that I turn to using Xmesh.
« Last Edit: February 26, 2015, 11:56:28 AM by cc8boy »
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.