Itoo Software Forum

Author Topic: Animation stops on random frames  (Read 1674 times)

QU8210

  • Newbie
  • *
  • Posts: 6
Animation stops on random frames
« on: July 22, 2013, 05:53:09 PM »
Hello!

This issue's been cropping up recently and I can't seem to find a fix for it.

Just as a heads up, I'm using Forest Pro 4.0.3 with 3ds Max 2012 x64.

The animation seems to stop at random frames or jumps around at random spots when rendered out with animation enabled.
I was using point cache'd meshes earlier thinking that was the problem and switched to animated vray proxies, with the same problems still popping up.
I've also tried rebuilding the forest object and the problem seems to pop up on a different spot on the animation. (see attachments)


Any help on this issue would be appreciated!

Thanks!


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Animation stops on random frames
« Reply #1 on: July 22, 2013, 06:16:45 PM »
I just rendered a simple test scene using proxies, and everything seems correct.

What is the result at viewport ? does it fail as well ?  Please, send us a stripped scene, we'll try to reproduce the problem here.
Carlos Quintero
iToo Software

QU8210

  • Newbie
  • *
  • Posts: 6
Re: Animation stops on random frames
« Reply #2 on: July 22, 2013, 07:47:19 PM »
Hey,

Thanks for the quick response!

Here's a download link: http://clients.567vfx.ca/Downloads/fp_field_V0015_0722.rar 

Scrubbing through the viewport is too slow to notice a change, so I have to rely on rendering low-res sequences to test scenes.

Just to take the trouble shooting a step further, I'm getting our IT guy to check if our render nodes have the latest version as well.


QU8210

  • Newbie
  • *
  • Posts: 6
Re: Animation stops on random frames
« Reply #3 on: July 22, 2013, 10:56:31 PM »
Update: we checked the render nodes and they're all up to date.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Animation stops on random frames
« Reply #4 on: July 23, 2013, 12:23:37 PM »
Thanks for the file. We are checking it, please hold on.
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Animation stops on random frames
« Reply #5 on: July 23, 2013, 02:28:22 PM »
We have done a couple of tests here, but they work fine (Max 2014, VRay 2.40.04, FP 4.0.3):

http://www.itoosoft.com/tmp/test_a.mov
http://www.itoosoft.com/tmp/test_b.mov

(in the second scene, the closed object is Forest, the farthest one is the proxy)

I think the problem would be with the render nodes. Please, try this and tell me if there is some difference:

1) Make a render test using a single workstation
2) Convert Forest to stand-alone objects using Forest Tools and render.

« Last Edit: July 23, 2013, 02:29:53 PM by iToo »
Carlos Quintero
iToo Software

QU8210

  • Newbie
  • *
  • Posts: 6
Re: Animation stops on random frames
« Reply #6 on: July 23, 2013, 04:46:15 PM »
I'll give those a shot, thanks!

QU8210

  • Newbie
  • *
  • Posts: 6
Re: Animation stops on random frames
« Reply #7 on: July 23, 2013, 06:46:34 PM »
We've done a few more tests on this end and the problem seems to be with 2012.

1. We've done your suggestion of converting Forest to individual objects and the renders are flawless through a single workstation and the render nodes, although now with the setback of having less of a flexibility working with a Forest object.

2. We've also tested rendering the same scene unconverted through 2013 and it seems to render fine as well through a single workstation.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Animation stops on random frames
« Reply #8 on: July 23, 2013, 06:55:41 PM »
Did you try using Max 2013 through the render nodes ?
What type of render network do you use, backburner or other ?

We will repeat our tests using Max 2012.

Carlos Quintero
iToo Software

QU8210

  • Newbie
  • *
  • Posts: 6
Re: Animation stops on random frames
« Reply #9 on: July 23, 2013, 07:16:58 PM »
We're on the process of installing the 2013 version of Forest Pack on the nodes right now and will test 2013 through the farm as soon as that's done. We use Deadline on the nodes.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Animation stops on random frames
« Reply #10 on: July 23, 2013, 07:40:15 PM »
Ok. I just repeated the test using Max 2012 without problems (single workstation).

Unfortunately we have not a render farm or Deadline here, to reproduce the problem under the same conditions.
Carlos Quintero
iToo Software