Itoo Software Forum

Author Topic: Animation using forest pack  (Read 232 times)

Michael

  • Newbie
  • *
  • Posts: 10
Animation using forest pack
« on: January 18, 2022, 10:26:20 AM »
Hello people of itoO!

I have a simple scene with 4 trees (mesh) that i have given some animation by adding noise onto their leaves and truck. I've then scattered those trees onto a path (with the option of placing trees on the vertices of the path) so i end up with a scene with 10-15 trees. I try to animate that scene with the forest animation set to follow geometry but my workstastion crashes after 40 frames since each frame cramps up more and more ram, so by the time we arrive at frame 40 we have all my ram (128GB!) finished.

Something is cleary wrong but i cant figure out what. Is it due to my settings on forest pack? Is it about my noise animated tree? i have watched the itoo tutorial for the animation but its not really the same case so i didnt find something usefull there for my problem. I need a subtle animation of the leaves.

How do you guys go about animating trees and scattering them? Does anyone have an idea why this is happening with my scene?

Thanks a lot in advance!

Michael

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2567
Re: Animation using forest pack
« Reply #1 on: January 18, 2022, 10:31:05 AM »
Hi Michael,

Sorry to hear you have that issue. Are you able to share a stripped version of your scene with us at helpdesk@itoosoft.com so that we can take a closer look?

Best,
Paul
Paul Roberts
iToo Software

Michael

  • Newbie
  • *
  • Posts: 10
Re: Animation using forest pack
« Reply #2 on: January 18, 2022, 01:25:13 PM »
Sure. I will prepare one and send it to you. Also somebody else tried something similar in my thread in the vray forum and had same results, if you guys wanna see as well i will post the link below.

https://forums.chaos.com/forum/v-ray-for-3ds-max-forums/v-ray-for-3ds-max-problems/1136836-problem-with-animating-multiple-frames#post1137025

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3969
    • iToo Software
Re: Animation using forest pack
« Reply #3 on: January 20, 2022, 12:17:05 PM »
Thanks for the scene. Testing it, we could find the problem.

Currently, Forest doesn't clear its cache for animated geometry between frames. We choosed thia approach for efficiency reasons, because extract meshes from animated objects may be slow.
For some animation modes, Forest needs to fetch the same samples on different frames multiple times. In this way, these samples are cached along the animation, and it's not necessary to compute them each frame.
But as side effect, the render cache requires more memory to store them.

I just added a mechanism to check the memory used. In this case specific scene, Forest cache takes 53Gb. just for 100 frames. That's is excessive.
We will try to optimize that for next updates.

Until then we suggest to divide long renders in several jobs. For example, instead to render from frame 0 to 100, create 10 separated render jobs of 100 frames. Cache is cleared when each render job is completed.
This can be done in Backburner, Batch render, or any other tool you use to render.

Please note this issue happens only with animated models, and Forest animation mode different from 'Disabled'. Static models have a single sample for the full animation, so render cache doesn't grow.

Carlos Quintero
iToo Software

Michael

  • Newbie
  • *
  • Posts: 10
Re: Animation using forest pack
« Reply #4 on: January 20, 2022, 02:09:46 PM »
Thank you guys for the time that you took to take a look! Something good came out of this and thats good! I will find another way to get my animated trees for now, or i will divide the render jobs like you said, thats also a good option.