Itoo Software Forum

Author Topic: Animation using LOD  (Read 276 times)

EE2934

  • Newbie
  • *
  • Posts: 9
Animation using LOD
« on: May 27, 2020, 03:03:18 PM »
Hi! I try to animate a huge scene with big trees count on streets. I using loads, and I see Forest rebuilding during animation. How to fix it? I want to forest hasn't any changes during the animation.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3275
    • iToo
Re: Animation using LOD
« Reply #1 on: May 27, 2020, 04:22:15 PM »
Sorry to hear you're facing these troubles. Might be, you are using the Camera - Distance Falloff feature?
When rendering a "walk-through" animations, this feature shouldn't be used to prevent any kind of troubles. As mentioned in our on-line reference guide:

"Be careful if you use falloffs with camera motion, because items may appear or disappear suddenly (the distance to camera changes when moving)."

Also, I would suggest you switch to the Custom Edit mode to see if there is any difference.

Optionally, you can do a quick test using Forest Tools and export all scattered geometry to instances. You can find it under Utilities - More ... - Forest Tools.
For more information about it, check our on-line reference guide. This way you can check that the problem happens during Forest object conversion or not.
Rokas
iToo Software

EE2934

  • Newbie
  • *
  • Posts: 9
Re: Animation using LOD
« Reply #2 on: May 27, 2020, 04:34:26 PM »
Sorry to hear you're facing these troubles. Might be, you are using the Camera - Distance Falloff feature?
When rendering a "walk-through" animations, this feature shouldn't be used to prevent any kind of troubles. As mentioned in our on-line reference guide:

"Be careful if you use falloffs with camera motion, because items may appear or disappear suddenly (the distance to camera changes when moving)."

Also, I would suggest you switch to the Custom Edit mode to see if there is any difference.

Optionally, you can do a quick test using Forest Tools and export all scattered geometry to instances. You can find it under Utilities - More ... - Forest Tools.
For more information about it, check our on-line reference guide. This way you can check that the problem happens during Forest object conversion or not.

I don't use distance falloff. Now I will check other.

EE2934

  • Newbie
  • *
  • Posts: 9
Re: Animation using LOD
« Reply #3 on: May 27, 2020, 04:57:55 PM »
Instantiate function works well, but it not useful, because i have many cameras and different Forest objects.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3275
    • iToo
Re: Animation using LOD
« Reply #4 on: May 27, 2020, 05:02:07 PM »
If You see LODs rebuilding, then it is too big of a difference/they change too close to the camera
Rokas
iToo Software

EE2934

  • Newbie
  • *
  • Posts: 9
Re: Animation using LOD
« Reply #5 on: May 27, 2020, 05:05:30 PM »
I place highpoly trees near the camera (20 m); midpoly (up to 100-200 m) and flat plans for the rest of the distance. I need to do that, just need freeze this condition.
« Last Edit: May 27, 2020, 05:57:03 PM by EE2934 »

EE2934

  • Newbie
  • *
  • Posts: 9
Re: Animation using LOD
« Reply #6 on: May 27, 2020, 06:10:47 PM »
If You see LODs rebuilding, then it is too big of a difference/they change too close to the camera

Is it possible to freese LODs rebuilding except Instantiating?

EE2934

  • Newbie
  • *
  • Posts: 9
Re: Animation using LOD
« Reply #7 on: June 09, 2020, 08:14:16 PM »
So, now I turned off LODs, but can't turn off Distance Density falloff. Grass instantiating looks like madness. How to freese a Forest?
« Last Edit: June 09, 2020, 08:19:50 PM by EE2934 »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3275
    • iToo
Re: Animation using LOD
« Reply #8 on: June 10, 2020, 07:53:33 AM »
Please send us Your scene( simplified) and more detailed description of what You would like to achieve.
We will continue conversation in email.
Rokas
iToo Software

EE2934

  • Newbie
  • *
  • Posts: 9
Re: Animation using LOD
« Reply #9 on: June 10, 2020, 03:42:00 PM »
I sent the scene to helpdesk@itoosoft.com.