Itoo Software Forum

Author Topic: Area Brush tool is Lag and not Responsive  (Read 855 times)

UQ4093

  • Newbie
  • *
  • Posts: 3
Area Brush tool is Lag and not Responsive
« on: June 16, 2014, 03:26:19 AM »
When Trying to Distribute Trees with Brush tool ...after some brushing the tool become lag and not responsive at all
Tried to make another layers of brush....good at first then after some another brushing become lag and not responsive
any suggestion?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Area Brush tool is Lag and not Responsive
« Reply #1 on: June 16, 2014, 09:05:13 AM »
This side effect is normal, because in Forest the Brush tool works in a very different way compared with other scattering packages: the Paint areas are parametric. That means that once painted you can modify parameters as density, distribution, type of plants etc.
Instead to place the items directly, Forest "paints" a spline on-the-fly, which is used as scattering region. For large areas this may cause lag, because the spline must be rebuild with each stroke.

There are several workarounds:

- As you pointed, create several Paint areas.
- Once completed, you can convert them to splines, edit or attach all together ("Convert to Spline" button).
- Alternatively, use the Custom Edit mode (Tree Editor rollout). It lets to add and edit items individually (although not a Brush tool), in a similar way to other packages. This mode has not lag, but you loose the benefits of the parametric edition.
Carlos Quintero
iToo Software

UQ4093

  • Newbie
  • *
  • Posts: 3
Re: Area Brush tool is Lag and not Responsive
« Reply #2 on: June 16, 2014, 12:57:11 PM »
Thank you for your fast reply.
Just asking can you make an option in a future update to force the tool not to auto update its parameter when you are painting until you finished painting and press paint icon again,and then the parameters gets its change....just paint the spline or area only in calculation mind not all parameters changing at once and when you finished it will update the scattering parameters or add an option for automatic/manual update to let users choose between realtime update and manual mode....i think it will be very nice regarding performance wise without loose quality.
Thank you

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Area Brush tool is Lag and not Responsive
« Reply #3 on: June 16, 2014, 01:20:25 PM »
Unfortunately that option will not improve the response on complex areas.
The problem is not the scattering process, but the deformation of the paint spline with each brush stroke (the orange gizmo you see in the viewport when painting). The processing time grows (and not linearly) with the complexity of this area.
Carlos Quintero
iToo Software

UQ4093

  • Newbie
  • *
  • Posts: 3
Re: Area Brush tool is Lag and not Responsive
« Reply #4 on: June 17, 2014, 12:40:43 AM »
Hope you can fix it...Thank you