Itoo Software Forum

Author Topic: Batch rendering  (Read 6238 times)

ivo-ott

  • Newbie
  • *
  • Posts: 11
Batch rendering
« on: March 18, 2008, 08:37:11 AM »
I noticed today, that Max batch rendering does not take notice of the trees (nor the planes) that should automatically face the camera. The trees stay in the starting rendering camera viewport position.
Any tip, how to get trees faceing the cameras in batch rendering?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Batch rendering
« Reply #1 on: March 18, 2008, 06:38:53 PM »
Hi,

What version of 3DS are you using ?

I just done a batch rendering test and works fine, using Max2008 64.
Carlos Quintero
iToo Software

ivo-ott

  • Newbie
  • *
  • Posts: 11
Re: Batch rendering
« Reply #2 on: March 20, 2008, 12:35:15 PM »
I am using the same version (max2008 64bit)

ivo-ott

  • Newbie
  • *
  • Posts: 11
Re: Batch rendering
« Reply #3 on: March 20, 2008, 12:50:24 PM »
Anyway, it didn't work for me.
I was using batch render not in command line state. Max2008 and the scene was started normally and then executed the batch render. I was also using different scene states (different environmental states, darker - lighter) for different views.
But I never touched the "trees faceing the camera automatically" feature, it was allways on.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Batch rendering
« Reply #4 on: March 20, 2008, 08:47:20 PM »

Yes, you are right, it doesn't work. I tested that trees follow the camera, but not the automatic assignation with multiple views.

Unfortunately, the Max function that we use to get the current viewport doesn't work with batch render. If possible, we will try to fix it for the next release.

As workaround, you may use network rendering but running locally (it's not the same... i know).

Carlos Quintero
iToo Software

BB1610

  • Jr. Member
  • **
  • Posts: 72
Re: Batch rendering
« Reply #5 on: October 15, 2009, 06:04:41 AM »
Hi,
it seems this issue appears also in 3.2.8b.

-R

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Batch rendering
« Reply #6 on: October 15, 2009, 07:57:56 PM »

Strange... this issue was fixed some versions ago. I just tested it (using 3.2.8b & Max2010-64) and seems to works fine.

Please, can you give me more information ?

Carlos Quintero
iToo Software

BB1610

  • Jr. Member
  • **
  • Posts: 72
Re: Batch rendering
« Reply #7 on: October 15, 2009, 11:23:28 PM »
Hi,
I`ve sent you a stripped scene, which looks ok when batchrender, but not in full state scene. Just check it out.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Batch rendering
« Reply #8 on: October 16, 2009, 05:06:12 PM »

Sorry, but i don't understand: if batchrender works, what is the problem: interactive render, viewport updating ?

Carlos Quintero
iToo Software

BB1610

  • Jr. Member
  • **
  • Posts: 72
Re: Batch rendering
« Reply #9 on: October 17, 2009, 12:13:09 AM »
Hi,
we misunderstood each other, we have problem with batch render + fp ( as was in older version of fp ), this problem occurs on full scene we`re rendering. In process to prepare scene for you to debug, i stripped the full scene of everything `unneeded` - and the stripped scene appears to be rendering in batch render correctly. So I thought - even if the scene renders correctly - that I`ll send you the stripped scene nonetheless - maybe you`ll find some another bug or so. I`m also trying to locate the problem, why the batch render doesnt work correctly with fp. ASAP I`ll find the problem, I`ll let you know.

-R

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Batch rendering
« Reply #10 on: October 17, 2009, 09:29:32 AM »

Did you have this problem before using Forest 3.2.8b ?

Although i didn't find bugs batch rendering your scene, i just realized of small issue related with the viewport updating. We will investigate it.

Carlos Quintero
iToo Software

BB1610

  • Jr. Member
  • **
  • Posts: 72
Re: Batch rendering
« Reply #11 on: October 17, 2009, 11:55:50 AM »
Did you have this problem before using Forest 3.2.8b ?
No, as we`re using batch render with fp only now for this project.