Itoo Software Forum

Author Topic: Bitmap Manager Error  (Read 1574 times)

OE1218

  • Newbie
  • *
  • Posts: 4
Bitmap Manager Error
« on: August 07, 2015, 07:20:02 PM »
Im running 3ds max 2015 and Forest Pro 4 3.7 
I cannot get Forest to run without the warning popping up multiple times Bitmap Manager Error.  It lists all the dismaps and says it cant find them.  I follow the path it states and they are all there where they should be.  Ive checked the user paths and I have deleted them out of there and restarted and had forest pack re path it.  Ive also input the paths manually and the problem persists. I am rendering through squidnet manager and it errors the entire animation with this bitmap manager Error.  Also Errors just when running on one blade.  Has anyone had this problem and fixed it other than how i have tried? 

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3093
    • iToo Software
Re: Bitmap Manager Error
« Reply #1 on: August 08, 2015, 05:14:22 AM »
This is a very unusual problem. By default Distribution maps are copied locally at "C:\Program Files (x86)\Itoo Software\Forest Pack Pro\distmaps\images", so Max should locate them without problems.
Additionally, they are handled also by the Asset Tracker. Even if the files are not in their original location, Max should search them in the User's texture paths.

Please, try this:

1) Reset Max and create a Forest object.
2) Open Asset Tracket (Shift T). What is the status of "spread1.bmp"  ?



3) If it's ok, repeat with one of your production scenes and compare the result.

Carlos Quintero
iToo Software

OE1218

  • Newbie
  • *
  • Posts: 4
Re: Bitmap Manager Error
« Reply #2 on: August 12, 2015, 01:04:30 PM »
I am rendering using a server that has 16 blades.  When i create a new forest object and check in the asset tracker it says Status OK.  When i open it on another one of the blades or try and distribute to that blade it says FILE MISSING. 

When it says file missing and i open a new file and create the same forest object it is fine in that file and says Status OK.???



OE1218

  • Newbie
  • *
  • Posts: 4
Re: Bitmap Manager Error
« Reply #3 on: August 12, 2015, 01:46:21 PM »
It seems that the Pathing is not staying relative?  When i create a forest object and open it on another blade/computer the pathing appears as absolute and looses its relative path. 

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Bitmap Manager Error
« Reply #4 on: August 13, 2015, 05:06:44 AM »
Hi,

Would you please double check your 3ds Max's Preference Settings? Have you the Convert local file paths to Relative under Files tab - Files Handling marked or not? Don't know how SquidNet is handling paths, but it potentially might be a related issue.

Best regards,

OE1218

  • Newbie
  • *
  • Posts: 4
Re: Bitmap Manager Error
« Reply #5 on: August 13, 2015, 08:31:22 PM »
It was unchecked.  As soon as i checked it the Bitmap Manager Error popped up on my local computer that the file was created on.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Bitmap Manager Error
« Reply #6 on: August 14, 2015, 11:26:02 AM »
Hi,

Well, it doesn't seem SquidNet has influence over 3ds Max File Handling and all works fine here with default settings (generally, for any network jobs we recommend to resolve all references to UNC paths).

Anyway, I would suggest you to save 3ds Max's Path Configuration File to .mxp (from the Configure User Paths dialog - Save As and under the Save Paths To File window save the path configuration as an MXP file) and load that while submitting a SquidNet Job under Basic Options - Path Configuration File. That should help to trace all necessary assets.

Best regards,

UE1700

  • Newbie
  • *
  • Posts: 1
Re: Bitmap Manager Error
« Reply #7 on: October 22, 2017, 03:51:21 AM »
Hi, I am getting the same error message, using latest Forest Pro.

I wasn't able to open Max asset tracker either, so I deleted the User ENU folder to reset this think they might have been related.  I still get the Bitmap error message when opening the file that includes forest things.  I'm only getting this message with the one file, other files containing forest pro objects are fine. 

I can't find any missing maps using a search script, and asset tracking shows no issues. 

It's when I open the file so nothing to do with DR rendering.  It renders the file, but  hang's after the render is complete so I can't save the image.

Any help?

Thank you

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Bitmap Manager Error
« Reply #8 on: October 23, 2017, 03:40:38 PM »
Hi,

It sounds like, that for some reason paths to Forest Pack's assets are missing / not properly mapped under your 3ds Max's configuration accessible by Customize - Configure User Paths - External files and stored in the 3dsmax.ini. The .ini file is located by default here:

C:\Documents and Settings\<username>\Local Settings\Application Data\Autodesk\3dsmax\<max version>\enu\3dsmax.ini

Actually, it's not necessary to configure these paths manually. When Forest is loaded, it's checking if these paths exist and if not, all of them could be added automatically (the plug-in shows a warning message). If you marked previously the Do not show this message again check-box to disable that pop-up window, you can revert it to its default value (to pop-up) by setting the checkTexturePaths = 1 in the forestpack.ini configuration file located by default at:
.
C:\Users\<username>\AppData\Local\Autodesk\3dsMax\<maxversion>\ENU\en-US\plugcfg

Hope that helps and please let us know that's all working fine or you are still facing troubles with it. Thanks in advance.

Best regards,