Itoo Software Forum

Author Topic: Bug / error on Auto assign to active view together with Batch Render  (Read 652 times)

Haider of Sweden

  • Newbie
  • *
  • Posts: 39
    • Portfolio
If the scene is too heavy, one wants to use the feature Auto assign to active view.
However, when using Batch Render, it seems that no refresh is been done.


Now that I might get the attention of IToo specialist;

- is this camera feature the only feature that does help in heavy scenes?

- I tried another approach, by assigning a camera for each forest object. Please see the image "01 Perspective" to understand the setup.
However if I understand the feature right, in the "02 Camera View", the other Forest Objects should not be active right? Or are they active as long as their respective camera is there?
//Haider

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #1 on: June 24, 2016, 06:10:57 PM »
Hi, i'm afraid that "Auto assign to active view" is not compatible with Batch render. This is an (old) known issue.

All Forest objects are enabled on render, regardless of the camera they have assigned. It just defines what camera use for clipping, for each one of them.

If possible, i suggest you configure a Backburner server locally and render using camera clipping with "Auto assign". This combination works fine, and once configured, i guess it's the best approach for large scenes.
Carlos Quintero
iToo Software

Haider of Sweden

  • Newbie
  • *
  • Posts: 39
    • Portfolio
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #2 on: June 26, 2016, 08:59:11 AM »
Thanks Carlos

So if I understand you correctly; 1) the Auto Assign is the only option where the clipping plane would cull away everything not see and that 2) this function only works in Backburner. Is that correct?

If so, I just need to double check, since I haven't used Backburner yet; I'd have to submit all the different cameras separately compared to the Batch Render where I have all the renders setup in advance?
//Haider

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1472
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #3 on: June 27, 2016, 10:12:38 AM »
Hi,

Exactly, unfortunately the Auto assign to active view feature isn't fully compatible with the Batch render (on recent 3ds max versions it should behave properly), but using Backburner you'll not face such limitation (it'll be reassigned automatically for different views).

Quote
"I'd have to submit all the different cameras separately compared to the Batch Render where I have all the renders setup in advance?"

Well, that's the usual way, but it's possible to send previously set-up Batch Render queue to Backburner (by enabling the Net Render option as on attached screenshot). Please check following "To Use the Batch Render Tool with Backburner: Overall Workflow" article for more details.

Hope you'll find it useful.

Best regards,

Haider of Sweden

  • Newbie
  • *
  • Posts: 39
    • Portfolio
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #4 on: December 22, 2016, 04:19:44 PM »
Hello again Michal,

I stumbled into this matter again and I am writing to make sure I understand the reason you suggested Batch Render.

If I understand Batch Render correctly, it saves a MAX file of the current state, and then renders that particular file.
Does it mean that the solution you describe would be equal to saving multiple MAX files, where each of them has the proper forest-camera assignment? And then either manually or with BAT file render one by one?
//Haider

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1472
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #5 on: December 27, 2016, 02:03:42 PM »
Hi,

Not exactly, the Batch Render just generates parameters needed for later rendering of all defined views in the queue (like the "-camera") and the Net Render option allows you to send all these defined views to the backburner (in a similar way like Submitting to Network Rendering these views one by one from the Render Setup window).

Best regards,

QL2487

  • Newbie
  • *
  • Posts: 10
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #6 on: April 27, 2017, 11:07:47 AM »
Hello,

sorry for reactivating this old thread. Is there any news if this issue is solved? I can confirm that Batch render + active view does not work in Max2016+forest 4.4.1.
"Net render" option for sending it to backburner does not help either.
Is this bug solved with some fresh max version or new forest?

Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: Bug / error on Auto assign to active view together with Batch Render
« Reply #7 on: April 27, 2017, 01:31:52 PM »
No, sorry. This problem was caused by a technical limitation of batch render, which we could not fix.


Carlos Quintero
iToo Software