Itoo Software Forum

Author Topic: Camera look at not working in 4.01  (Read 1437 times)

theedge

  • Newbie
  • *
  • Posts: 31
Camera look at not working in 4.01
« on: March 25, 2013, 11:43:01 AM »
Hello,
I updated recently to FP 4.01
Looks like the look-at camera doesn't have any effect . Specifying a look-at target does work. But Camera, wether selecting one or using auto-assign to active view doesn't work.
Is it just me ?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
    • iToo Software
Re: Camera look at not working in 4.01
« Reply #1 on: March 25, 2013, 11:49:35 AM »

Please adjust the Camera->Back Offset parameter. The default value (10 meters) would be too high for your scene's scale.

Carlos Quintero
iToo Software

theedge

  • Newbie
  • *
  • Posts: 31
Re: Camera look at not working in 4.01
« Reply #2 on: March 25, 2013, 12:06:37 PM »
I think I was not clear, sorry.
In the previous version I used to activate the "Trees Facing Camera" checkbox ans also "Use on custom objects" so that my 2d billboards are oriented correctly towards the camera. Now these options disappeared from the camera section. Maybe they moved somewhere else ?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
    • iToo Software
Re: Camera look at not working in 4.01
« Reply #3 on: March 25, 2013, 12:24:06 PM »

We changed slightly the behaviour to include the new "Look-At" mode:

a) The Billboard items (Geometry->Template) look at the active camera automatically, if Camera->Look-At->On is enabled.
b) For standard objects (Geometry->Custom Object) it is necessary to assign the target (that may be a camera or something else) to Camera->Look-At->Target and enable the "On" checkbox.

This allow to use a separate target for the Look-At feature, while using the Camera clipping.

Carlos Quintero
iToo Software

theedge

  • Newbie
  • *
  • Posts: 31
Re: Camera look at not working in 4.01
« Reply #4 on: March 25, 2013, 12:39:41 PM »
So, if I want to render 6 images from 6 different cameras, I'll have to re-assign the camera every time ?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
    • iToo Software
Re: Camera look at not working in 4.01
« Reply #5 on: March 25, 2013, 12:54:42 PM »

Not really. If you use the predefined billboards (Geometry->Template), they look at the active camera by default.

Are you using your own custom objects as billboards ?

Carlos Quintero
iToo Software

theedge

  • Newbie
  • *
  • Posts: 31
Re: Camera look at not working in 4.01
« Reply #6 on: March 25, 2013, 01:45:39 PM »
Yes indeed. I use my own custom objects to scatter people.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
    • iToo Software
Re: Camera look at not working in 4.01
« Reply #7 on: March 25, 2013, 02:19:21 PM »

I see. Unfortunately with the new method it is not possible to assign the camera automatically as Look-At target for custom objects.

Would be possible you use billboard templates instead ? They have some advantages, i.e. the self-shadowing issues are fixed automatically at rendering. You would create your own custom library of 2D people as well.

Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
    • iToo Software
Re: Camera look at not working in 4.01
« Reply #8 on: March 25, 2013, 04:49:05 PM »

Please, forget my last post. I just added a new parameter (Auto Assign to Active View->Apply To Look At), to put back the previous functionality. It will be included in the next update (for immediate release).

Carlos Quintero
iToo Software